Bug 53516 - Gnome Terminal 1.4.0.4 Does Not Display ISO-8859-9 Chars Correctly
Summary: Gnome Terminal 1.4.0.4 Does Not Display ISO-8859-9 Chars Correctly
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-libs (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-10 19:14 UTC by Ecmel Ercan
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 21:08:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ecmel Ercan 2001-09-10 19:14:57 UTC
Description of Problem:
With Red Hat 7.1 Gnome Terminal perfectly displayed ISO-8859-9 chars.  But
with Roswell, Gnome Terminal 1.4.0.4 does not display them.

Version-Release number of selected component (if applicable):
1.4.0.4

How Reproducible:
Every time

Steps to Reproduce:
1. Run Gnome Terminal
2. Select a ISO-8859-9 (e.g. Fixed (misc) 12)
   (or any other one - I tried many)

Actual Results:
Trash glaphys for ISO-8859-9 specific characters

Expected Results:
Correct glaphys ISO-8859-9 specific characters

Additional Information:

Comment 1 Havoc Pennington 2001-09-10 20:11:29 UTC
What is your locale? (echo $LANG)

Comment 2 Ecmel Ercan 2001-09-10 21:08:54 UTC
en_US

I prefer to use Gnome in English but want to be able to write and read Turkish
ISO-8859-9 chars.

Comment 3 Havoc Pennington 2001-09-14 21:36:48 UTC
If youu want to use fonts in an encoding other than your current locale's
encoding, you have to go into gnome-terminal preferences and uncheck
the "multibyte support" option. This will break all non-8-bit encodings, because
using fonts from another locale is just an accidental feature of the fact that
all the encodings you care about are 8-bit.

If that doesn't fix it, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.