This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 535198 - (RHQ-191) Changing Items Per Page does not work
Changing Items Per Page does not work
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
0.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-692
  Show dependency treegraph
 
Reported: 2008-03-26 19:59 EDT by Mark Spritzler
Modified: 2010-08-25 11:39 EDT (History)
0 users

See Also:
Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 11:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Spritzler 2008-03-26 19:59:00 EDT
Here is what I had done to get it to not work.

1. I changed the items per page to 45
2. Filtered on War deployments.
3. Refresh the page.
4. Try to change the items per page to anything else no longer works.
Comment 1 Joseph Marques 2008-04-04 16:18:01 EDT
this is YET ANOTHER fall-out of ajax-y partial page requests.  since we're not actually updating the dom history, the browser never records that you've changed filter (in this case to war deployments).  so when you refresh the page, what you see is not the real state of things.  if you were to change the filter, and then change the paging, things work properly.  you should notice that after you refresh you'll see ALL of the original items (as if no filter was applied) even though the filter still shows, in this case, war deployments.
Comment 2 Red Hat Bugzilla 2009-11-10 15:49:29 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-191
Comment 3 Corey Welton 2010-08-25 11:39:34 EDT
Closing per 25-Aug triage.

Note You need to log in before you can comment on or make changes to this bug.