Bug 5352 - rpm -q not available to non-root users
Summary: rpm -q not available to non-root users
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-24 22:15 UTC by Chris Runge
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-24 23:11:04 UTC


Attachments (Terms of Use)

Description Chris Runge 1999-09-24 22:15:58 UTC
Under Lorax 6.0.80 non-root users can no longer rpm -q
packages:

$ rpm -q kernel
failed to open //var/lib/rpm/packages.rpm

rpmQuery: rpmdbOpen() failed

This is with rpm-3.0.3-0.32 installed

Comment 1 Jeff Johnson 1999-09-24 23:11:59 UTC
Check perms on /var/lib/rpm/* files. If they are 000, this problem
(naively believing what the installer passes for permissions) has
been fixed. Otherwise, please reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.