Bug 53526 - aclocal error handling fix
Summary: aclocal error handling fix
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: automake (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-10 21:56 UTC by Havoc Pennington
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-28 17:53:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
don't consider duplicate macros a fatal error (536 bytes, patch)
2001-09-10 21:58 UTC, Havoc Pennington
no flags Details | Diff

Description Havoc Pennington 2001-09-10 21:56:57 UTC
aclocal keeps any package that installs .m4 macros from working properly 
if I put build it in two separate prefixes, one of which is the 
standard aclocal build location.

This is because even if I pass "-I /prefix/share/aclocal" when using 
aclocal in "/prefix", aclocal has a fatal error if it finds duplicate
macros. There is no reason this error should be fatal.

Will attach Owen's patch for this.

Comment 1 Havoc Pennington 2001-09-10 21:58:58 UTC
Created attachment 31539 [details]
don't consider duplicate macros a fatal error

Comment 2 Tom Tromey 2001-11-28 17:53:07 UTC
FYI: the aclocal that comes with automake 1.5 no longer
generates this error.  There were too many complaints and
problems associated with it, so we took it out.


Comment 3 Havoc Pennington 2001-11-28 18:39:33 UTC
Perfect, 1.5 is in rawhide so I guess the bug is closed.


Note You need to log in before you can comment on or make changes to this bug.