Bug 53530 - check_default_route () very slow on machines with many routes
check_default_route () very slow on machines with many routes
Status: CLOSED DUPLICATE of bug 66263
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-10 19:25 EDT by Dan Hollis
Modified: 2014-03-16 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2001-09-10 19:25:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9 i586; Nav)

Description of problem:
On redhat 7.1 systems configured as bgp routers, check_default_route() in
/etc/sysconfig/network-scripts/network-functions can take upwards of 5-10
minutes to execute... (think on the order of 150,000 routes...)

The obvious solution is to make check_default_route () use 'ip ro list
match 0.0.0.0/0' or something similar instead of the extremely slow and
costly piping 'route -n' into gawk.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install redhat 7.1
2. setup zebra as a bgp peer and get 150,000 routes from another bgp peer
:-)
3. try to shutdown the box with ctrl-alt-del, go get some coffee because
its going to be a long wait... :-(
	

Additional info:
Comment 1 Terje Bless 2003-10-04 10:25:59 EDT
Isn't this a duplicate of Bug #66263 (which has been "CLOSED RAWHDE")?
Comment 2 Bill Nottingham 2003-10-06 01:34:43 EDT

*** This bug has been marked as a duplicate of 66263 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:48:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.