Bug 535365 - (RHQ-2069) Events - server doesn't seem to recognize log lines in newly created log file
Events - server doesn't seem to recognize log lines in newly created log file
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Events (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Charles Crouch
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage jon3 912547
  Show dependency treegraph
 
Reported: 2009-05-08 16:24 EDT by Jeff Weiss
Modified: 2015-02-01 18:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 912547 (view as bug list)
Environment:
1.2.0GA, linux
Last Closed: 2014-05-05 16:43:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2009-05-08 16:24:00 EDT
How to repeat:

Create a new event source on the RHQ server.  'touch' the file to create it.  Wait 2 minutes.  now echo into the file lines like this (change datestamps if necessary):

2009-05-08 15:57:41,170 INFO [my.class1] AutomationMsg First info level message
2009-05-08 15:57:41,420 DEBUG [my.class2] AutomationMsg First debug level message
2009-05-08 15:57:41,671 WARN [my.class3] AutomationMsg First warn level message
2009-05-08 15:57:41,921 ERROR [my.class4] AutomationMsg First error level message
2009-05-08 15:57:42,171 FATAL [my.class5] AutomationMsg First fatal level message
2009-05-08 15:57:42,421 INFO [your.class1] AutomationMsg Second info level message
2009-05-08 15:57:42,672 DEBUG [your.class2] AutomationMsg Second debug level message
2009-05-08 15:57:42,922 WARN [your.class3] AutomationMsg Second warn level message
2009-05-08 15:57:43,172 ERROR [your.class4] AutomationMsg Second error level message
2009-05-08 15:57:43,422 FATAL [your.class5] AutomationMsg Second fatal level message

wait 2 minutes.  Now check the Events tab on the RHQ server to see if the events are there.  They don't show up.  Now, wait 2 minutes, then run 'touch' again on the log file to update the modification date.  Wait 2 minutes.  Refresh the events page.  Still no events.

Now run "tail -10 [logfile] >> [logfile]" which basically adds another 10 lines to the end of the file that match what's already there (since the file is 10 lines).  Wait 2 minutes.  Refresh.  Now there are 8 events.  The 2 that are missing are the DEBUG level events even though DEBUG is checked in the filter.

'touch' the file again.  Wait 2minutes, refresh.  Still no new entries.
Comment 1 Jeff Weiss 2009-05-08 16:40:41 EDT
I now realize the lack of DEBUG messages is expected, I was creating the source with the default level of INFO.  However the other problem remains unexplained.
Comment 2 Red Hat Bugzilla 2009-11-10 15:57:08 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2069
Comment 3 wes hayutin 2010-02-16 11:57:51 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 12:02:44 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.