Bug 535386 - (RHQ-2088) add Start Time trait to the RHQ Agent ResourceType
add Start Time trait to the RHQ Agent ResourceType
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Mike Foley
http://jira.rhq-project.org/browse/RH...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 08:09 EDT by Ian Springer
Modified: 2014-05-05 16:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-05 16:52:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2009-05-14 08:09:00 EDT
I think these would be handy, especially when troubleshooting Agent JVM crashes as I have been recently.
Comment 1 John Mazzitelli 2009-05-14 08:32:43 EDT
We already have a "uptime" metric. It is not appropriate for a trait, it changes everytime it is collected. It is off by default, you have to enable it (see: defaultOn="false").

      <metric property="Uptime"
              displayName="Up Time"
              description="Total number of seconds since the agent was started"
              defaultOn="false"
              units="seconds"
              category="availability"
              measurementType="dynamic" />  <!-- changed to dynamic to prevent generation of per Minute metric. -->

Comment 2 John Mazzitelli 2009-05-14 08:33:26 EDT
changing subject to "add start time trait" - we already have uptime metric.
Comment 3 Charles Crouch 2009-09-01 12:04:20 EDT
Move features/improvements to 1.4
Comment 4 Red Hat Bugzilla 2009-11-10 15:57:30 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2088

Note You need to log in before you can comment on or make changes to this bug.