Bug 535427 - (RHQ-2123) Add "backup" and "rollback" functionality for JBoss CP upgrades
Add "backup" and "rollback" functionality for JBoss CP upgrades
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Operations (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 14:20 EDT by Mark Burchard
Modified: 2014-05-05 16:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
N/A
Last Closed: 2014-05-05 16:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Burchard 2009-06-01 14:20:00 EDT
This came about after discussions with a customer after an EAP 4.3 CP_03 > CP_04 that went wrong and prevented the target EAP servers from starting[1][2].   If they had not been wise and tested on a few non-production servers, the failed upgrade would have broken all ~200 of their deployed JBoss servers.

In the manual CP upgrade instructions, we stress that the target JBoss instance be backed up prior to starting the upgrade.  It only makes sense to try and follow this  procedure during an upgrade from JON.

Is this feasible?  



[1]https://enterprise.redhat.com/issue-tracker/302025
[2]https://enterprise.redhat.com/issue-tracker/298056

Comment 1 Mark Burchard 2009-07-07 12:26:49 EDT
Ok, looks like I was mistaken, ran across this while doing a CP upgrade:

#
Package: JBoss EAP 4.3.0.GA_CP04 4.3.0.GA_CP04
#

The following steps were provided by the plugin. They describe the steps that will take place during the deployment of this package. Please review the steps before deciding whether or not to continue with the deployment.
Step Number     Description
1       Download file from the server and save it to [#{downloadFolder}/#{software.filename}].
1       Calculate the digest of [#{downloadFolder}/#{software.filename}] using the [MD5] algorithm and check it matches [#{software.MD5}].
1       Unzip [#{downloadFolder}/#{software.filename}] into [#{patchFolder}].
1       Carry out [stopIfRunning] action on the server.
1       Backup and replace [#{jbossServerHomeDir}/deploy/management/console-mgr.sar/web-console.war/applet.jar].
1       Backup and replace [#{jbossServerHomeDir}/deploy/management/console-mgr.sar/console-mgr-classes.jar].
<snip>
Comment 2 Charles Crouch 2009-07-07 13:19:37 EDT
Right Mark, we backup all files which get updated by the CP process, but the restore is still a manual process.
Comment 3 Red Hat Bugzilla 2009-11-10 15:58:18 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2123
Comment 4 wes hayutin 2010-02-16 12:09:24 EST
mass add of key word FutureFeature to help track
Comment 6 Corey Welton 2010-12-23 09:29:03 EST
Triaged 20-Dec

Note You need to log in before you can comment on or make changes to this bug.