Bug 535451 - (RHQ-2145) InventoryManager.initialize should go faster
InventoryManager.initialize should go faster
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
1.2
All All
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
Push to 1.4
: FutureFeature, SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-06-11 11:35 EDT by John Mazzitelli
Modified: 2014-05-05 17:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-05 17:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-06-11 11:35:00 EDT
When the PC initializes, it calls all the managers' initialize() methods. It does so while holding a write lock so nobody can access the managers until they are all started.

The InventoryManager initialize does "executePlatformScan();" which in turns merges discovery and initializes the resource containers. This could take a long time.

We need to either speed that up or do it in an asynchronous mechanism to allow the InventoryManager.initialize to return (assuming that doesn't break anything - the IM must be fully iniitalized before returning fro initialize() method).
Comment 1 Charles Crouch 2009-06-11 11:49:43 EDT
This long initialize time seems to have been the cause of some exceptions in case 301319
Comment 2 Red Hat Bugzilla 2009-11-10 15:58:44 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2145
Comment 3 wes hayutin 2010-02-16 11:55:08 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 12:00:17 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.