Bug 53546 - jw breaks when both -d and -o are used
jw breaks when both -d and -o are used
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: docbook-utils (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-11 04:04 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-28 17:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's the fix. (2.85 KB, patch)
2001-09-28 17:44 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2001-09-11 04:04:45 EDT
Description of Problem:
jw can't handle both the -d and -o options at once.

Version-Release number of selected component (if applicable):
docbook-utils-0.6.9-2

How Reproducible:
100%

Steps to Reproduce:
1. jw -f docbook -b html -o html -d file.dsl file.sgml

Actual Results:
Command fails.

Expected Results:
Command puts output in html/ and uses file.dsl as its stylesheet.

Additional Information:
This is because jw actually enters the output directory before calling 
the backend.  It should convert relative file names to absolute file 
names before doing so.
Comment 1 Tim Waugh 2001-09-28 17:44:12 EDT
Created attachment 32978 [details]
Here's the fix.
Comment 2 Tim Waugh 2001-10-22 04:50:51 EDT
Fixed in docbook-utils-0.6.9-5.

Note You need to log in before you can comment on or make changes to this bug.