Bug 535460 - (RHQ-2153) ./rhq-server.sh start message could be more helpful [NEEDINFO]
./rhq-server.sh start message could be more helpful
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-06-16 13:02 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-05 17:40:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
cwelton: needinfo? (ccrouch)


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-06-16 13:02:00 EDT
When you start the server it says

[root@domU-12-31-39-04-39-E5 bin]# ./rhq-server.sh start
Trying to start the RHQ Server...
RHQ Server (pid 2285) is starting

I assumed 2285 is the pid of the JVM since that *is* the RHQ server, however 2285 is the pid of the run.sh wrapper script process.
We have the pid of the jvm, its in rhq-jvm.pid, so we should display that instead, since its the process most people are going to be interested in monitoring,  not the wrapper script.
Comment 1 Corey Welton 2009-08-05 14:02:43 EDT
Push to  1.4
Comment 2 Red Hat Bugzilla 2009-11-10 15:58:53 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2153
Comment 3 wes hayutin 2010-02-16 11:56:12 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 12:01:22 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.