This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535475 - (RHQ-2166) missing LateCollections metric in rhq agent plugin
missing LateCollections metric in rhq agent plugin
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 13:56 EDT by John Mazzitelli
Modified: 2014-11-09 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-06-18 13:56:00 EDT
We are missing a "late collections" metric defined in the agent plugin.

From rhq-agent plugin's descriptor (note: 4 metrics):

         <metric property="CurrentlyScheduleMeasurements" displayType="summary"
                 description="The total number of active measurement schedules currently being collected by this RHQ Agent"/>
         <metric property="MeasurementsCollected" measurementType="trendsup" displayType="summary"
                 description="The total number of measurements collected since this RHQ Agent was started"/>
         <metric property="TotalTimeCollectingMeasurements" displayType="summary" units="milliseconds" measurementType="trendsup"
                 description="The amount of time this RHQ Agent has spent collecting measurements since it was started"/>
         <metric property="FailedCollections" displayType="summary" measurementType="trendsup"
                 description="The number of individual measurement collections that have failed since this RHQ Agent was started"/>

but the MeasurementManagerMBean has this (notice the getLateCollections method)

public interface MeasurementManagerMBean {

    long getMeasurementsCollected(); // metric #2 above
    long getMeasurementsCollectedPerMinute(); // ignored, we use getMeasurementsCollected in the descriptor above
    long getCurrentlyScheduleMeasurements(); // metric #1 above
    long getTotalTimeCollectingMeasurements(); // metric #3 above
    long getNextExpectedCollectionTime(); // ignored, we do not collect this
    long getLateCollections(); // WHY DOESN'T THE PLUGIN DEFINE A <metric> FOR THIS?????
    long getFailedCollections(); // metric #4 above
Comment 1 John Mazzitelli 2009-06-18 13:59:01 EDT
added this to rhq-plugin.xml for the agent plugin:

         <metric property="LateCollections" displayType="summary" measurementType="trendsup"
                 description="The number of individual measurement collections that have fallen behind from their desired schedule"/>
Comment 2 Jeff Weiss 2009-06-29 14:06:04 EDT
This metric now appears under Measurement Subsystem.  rev4181
Comment 3 Red Hat Bugzilla 2009-11-10 15:59:07 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2166

Note You need to log in before you can comment on or make changes to this bug.