Bug 535476 - (RHQ-2167) add ability to manually set baselines across multiple resources at the same time
add ability to manually set baselines across multiple resources at the same time
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 15:18 EDT by Joseph Marques
Modified: 2014-11-09 17:49 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-06-18 15:18:00 EDT
use case:

* i have baseline-based alert definitions setup across my inventory
* something happens in my enterprise which causes me to change a configuration, which alters metrics coming out of some service
* these new metrics begin firing lots and lots of alerts incorrectly

the problem:

* if the baselines had been recalculated given the new/recent data, they would realize that the old baseline no long applies because the metrics have a different range now

the solution:

* allow baselines to be set manually using a custom range of data (this is possible today across a single measurement schedule at a time, but needs to be supported across a group of resources to be really useful)
Comment 1 Joseph Marques 2009-06-18 15:19:27 EDT
i believe most of the code for this already exists at the SLSB layer, just need to extend the UI logic in the singleMetricSingleResource case to the singleMetricMultipleResource case.
Comment 2 Joseph Marques 2009-07-12 15:50:07 EDT
rev4373 - ability to set manual baselines across a resourceGroup at the same time; 
Comment 3 Joseph Marques 2009-07-12 15:59:15 EDT
when you navigate to a large metric chart for a group you'll now see the "Metric Baseline & Expected Range" section, just as you do for single resources.  i made sure there was feature parity with the setting of baselines at the resource level, which means:

* when you first navigate to the page, if NO baselines for the given metric have been calculated in the group, a standard "No value yet" error message will be displayed
* you can click change value for a baseline mean, it will calculate the baseline mean by taking the average value over the given display range; it will then let you accept that value or cancel it; if you want it to calculate a different value, you need to change the values for your metric display range - note: setting the baseline mean will also recalculate the min and max
* you can click change values for a baseline max, it will give you an editable box, and you can set the max to whatever you want or cancel
* you can click change values for a baseline min, it will give you an editable box, and you can set the min to whatever you want or cancel

additional features for groups only:

* if the members of the group have different baseline values for the given metric, it will display "Multiple Values"; if all values in the group for the given baselines are identical, it will display that value
Comment 4 Jeff Weiss 2009-08-03 15:12:31 EDT
Was able to set baselines on individual resource by setting it on the group.  Changed a value of an individual and saw "multiple values" on the group.  rev4650
Comment 5 Red Hat Bugzilla 2009-11-10 15:59:08 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2167
Comment 6 wes hayutin 2010-02-16 16:10:13 EST
Mass move to component = Monitoring

Note You need to log in before you can comment on or make changes to this bug.