Bug 535478 - (RHQ-2169) RT connector bundled in snmp_module-x64-linux-apache2.2.zip is not HTTPD 2.2-compatible
RT connector bundled in snmp_module-x64-linux-apache2.2.zip is not HTTPD 2.2-...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: jon241-bugs
  Show dependency treegraph
 
Reported: 2009-06-22 17:10 EDT by Mark Burchard
Modified: 2011-01-05 23:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OS: Red Hat Enterprise Linux Server release 5.3 (Tikanga) Linux rhel53x64adm01.localdomain 2.6.18-128.1.14.el5 #1 SMP Mon Jun 1 15:52:58 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux HTTPD Name : httpd Arch : x86_64 Version : 2.2.11 Release :
Last Closed: 2011-01-05 23:34:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Burchard 2009-06-22 17:10:00 EDT
When apache tries to load the mod_rt.so binary module packaged in snmp_module-x64-linux-apache2.2.zip, it throws the error:

Starting httpd: httpd.worker: Syntax error on line 1003 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_rt.so into server: /etc/httpd/modules/mod_rt.so: invalid ELF header

File says it's a 32-bit executable:

 file  ../../../modules/mod_rt.so 
../../../modules/mod_rt.so: PE32 executable for MS Windows (DLL) (GUI) Intel 80386 32-bit


I compiled a new one from sources like so:

./build_apache_module.sh 2.x /usr/sbin/apxs

File reports a 64-bit executable:

 file .libs/mod_rt.so 
.libs/mod_rt.so: ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), not stripped

httpd starts fine after this, rt module is loaded according to apachectl -M


This possibly affects binary module distributions in connector packages for other arches/httpd versions.






Comment 1 Red Hat Bugzilla 2009-11-10 15:59:10 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2169
Comment 2 wes hayutin 2010-02-16 11:54:19 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 11:59:43 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 wes hayutin 2010-02-16 16:09:59 EST
Mass move to component = Monitoring
Comment 6 Corey Welton 2010-12-23 09:35:44 EST
ccrouch - Anything to do here for 241?
Comment 8 Lukas Krejci 2011-01-03 11:25:44 EST
I don't think there is an issue here.

1) mod_rt.so is *NOT* packaged inside snmp_module-x64*
2) we don't package linux binaries of mod_rt at all (this might be considered a bug)
3) even the original bug description mentions that the mod_rt.so it tries to load is an windows DLL being used on Linux, which of course won't succeed. This is probably because the only mod_rt binary we package is the Windows 32bit binary and Mark mistakenly tried to use it on Linux.
Comment 9 Charles Crouch 2011-01-04 18:58:23 EST
Sounds like we're fine here, but lets take this opportunity to have QE test our regular Apache 2.2 monitoring and the RT monitoring when Apache 2.2 is deployed on Linux 64bit.
Comment 10 Corey Welton 2011-01-05 23:34:55 EST
Re: SNMP monitoring

We have actually been doing the bulk of our Apache testing on 2.2 systems.  I went to configure it on a test box only to find the bits already there from a past installation.  This box is, and has been, running Apache 2.2.  I had to regenerate the httpd.conf lines that had been wiped out from other test efforts long ago, but after that, the monitored httpd in inventory is green and being monitored just fine.

Re: RT monitoring

It is not a "bug", per say, that there is no binary - the steps to build are doc'ed:

http://docs.redhat.com/docs/en-US/JBoss_Operations_Network/2.4/html/Resource_Monitoring_and_Operations_Reference/Managed_Servers.html#sect-Apache_HTTP-Apache_2_Response_Time_Configuration

So why are there no builds for Linux (and/or other *nix platforms)?  Presumably because

a) there were never *nix binaries delivered from the original provider (as is often there case - sources are delivered for *nix but binaries are delivered for Win),
b) no one in dev was familiar with the black art of the SNMP connector stuff, and/or
c) to actually compile the rt filter is a trivial matter, as illustrated in the initial report (and contrary to what it might seem in the documentation).

We can bug the lack of a mod_rt.so for linux as a future feature -- though I'd argue it'd be more flexible in the long run to, if anything at all, try and provide a reasonable shell script is provided rather than having to keep add new binaries every time a new platform, arch or apache release comes out.

Back to the functional aspect - it seems to be working, at least as best I understand it.  the .so compiles, httpd loads the .so, and monitoring seems to be just fine...

But as for the root of this bug itself, it's invalid. 

QA Closing.

Note You need to log in before you can comment on or make changes to this bug.