Bug 53548 - rpm --queryformat hangs
rpm --queryformat hangs
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2001-09-11 06:11 EDT by Michael Redinger
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-11 06:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2001-09-11 06:11:29 EDT
Description of Problem:
Not sure if this is the same as eg. #50992 - but as that bug was fixed in rpm-4.0.3-0.87 this should be different:

When doing rpm queries, rpm hangs. You have to stop it and remove
/var/lib/rpm/__db* , then everything works fine again.

There doesn't seem to be an obvious reason why something breaks.
Eg. I did a rpm -qa --querytags .... Worked fine. I played around
a bit to include all the tags needed, and suddenly rpm stopped 

I also experienced cases where rpm -qa still worked, but 
rpm -qa --querytags didn't.

Version-Release number of selected component (if applicable):

How Reproducible:
Hm, I think that's just playing around and waiting until it breaks ... nothing more specific ... :(

Actual Results:
rpm hangs

Expected Results:
rpm should not hang ... :)
Comment 1 Jeff Johnson 2001-09-12 12:47:26 EDT
Yup, if you dink around enough, particularly if you
use ^C a lot, you will find yourself with an
invalid cache (i.e. the /var/lib/rpm/__db* files).

The answer for rpm-4.0.3 is basically
    Don't do that.
and, if you ignore that message, then do
    rm -f /var/lib/rpm/__db*
when the problem reoccurs.

Yes, rpm-4.0.3 removes those files when starting,
but that doesn't work if, say, you've ^C'd out
of a root install, and are running an rpm query
w/o root privileges.

The solution is going to be to make rpm setgid
rpm, but there's more release engineering needed
in order to achieve this.

Note You need to log in before you can comment on or make changes to this bug.