Bug 53551 - telnet update to 0.17.6x-18 changes default "mode" behaviour
telnet update to 0.17.6x-18 changes default "mode" behaviour
Status: CLOSED DUPLICATE of bug 56679
Product: Red Hat Linux
Classification: Retired
Component: telnet (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-11 08:45 EDT by Ralf Ertzinger
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-15 04:57:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2001-09-11 08:45:10 EDT
Description of Problem:
When using the updated telnet client to connect to a Bianca/BrickXL (a ISDN dialin router), the default linemode has changed from the behaviour of telnet-0.16-6 (RH 6.2 default).
When using 0.16-6, linemode is negotiated as follows:

telnet> status
Connected to xxxxxxxxxxxxx
Operating with LINEMODE option
.....

Using 0.17.6x-18:
telnet> status
Connected to xxxxxxxxxxx
Operating in obsolete linemode
....


Unfortunately, the router in question does not like the obsolete linemode (this is how I noticed the problem).


Version-Release number of selected component (if applicable):
0.17.6x-18


How Reproducible:
Always

Steps to Reproduce:
1. Use telnet to connect to the router in question
2. Issue a telnet escape sequence
3. use "status" to check linemode

Actual Results:
telnet is using "obsolete linemode"


Expected Results:
telnet should use "LINEMODE"


Additional Information:
Looking at a tcpdump output of the connection I noticed that telnet-0.16-6 (the old one) sends one packet more than telnet-0.17 (the new one).
The packet in question is sent from the client to the server, and contains option negotiations.
The options negotiated in 0.16 but not in 0.17 are:
- Do suppress go ahead
- will Terminal Type
- will negotiate about window size
- will Terminal Speed
- will Remote Flow Control
- will Linemode                             (sic!)
- will New Environment Option
- Do Status
Comment 1 ted_rule 2002-02-15 04:57:14 EST
This is almost certainly the same bug as that associated with BugZilla ID
56679, namely that all telnet option negotiation is effectively disabled by 
default. Please see my comments and suggested patch and possible workround in 
that BugZilla ID for more information.
Comment 2 Harald Hoyer 2002-02-28 05:58:48 EST

*** This bug has been marked as a duplicate of 56679 ***

Note You need to log in before you can comment on or make changes to this bug.