This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535524 - (RHQ-220) Incorrect cached value for group member connection property
Incorrect cached value for group member connection property
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-692
  Show dependency treegraph
 
Reported: 2008-04-01 17:20 EDT by Jay Shaughnessy
Modified: 2014-11-09 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Tested on Vista
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2008-04-01 17:20:00 EDT

1) Create a compatible group of JBAS servers (a single group member is fine)

2) Ensure the necessary JBAS server agent(s) are running

3) For the new group, go to Inventory connection properties

4) override and change the setting for Shutdown method

5) Allow the asynch update to complete 

6) Verify that the group connection properties now reflect the updated value

7) Now, select a group member (on of the JBAS server resources in the group)

8) Navigate to its conn properties

The value shows the old setting although in reality it has been updated.  Starting a new session will show the updated value.

Comment 1 Charles Crouch 2008-04-01 17:51:06 EDT
Not seeing your update I think merits being major. From ips/joseph's discussion this is related to the lack of conversation scoped context which we have been trying to work around.
Comment 2 Jessica Sant 2008-04-15 23:05:20 EDT
another manifestation of this problem in r629 / r9861

(10:45:31 PM) jsant: k - go to http://10.11.15.96:7080/rhq/resource/inventory/view.xhtml?id=500787  (a Windows | Inventory page)
(10:45:43 PM) jsant: and open that page in 2 different browsers 
(10:45:50 PM) jsant: IE and FF maybe
(10:46:36 PM) jsant: notice that connection propert event log has a regular expression defined
(10:46:53 PM) jsant: in one of your browsers, edit that field and "unset" the regex field, and save it
(10:47:20 PM) jsant: refresh the page in your 2nd browser -- the regex will remain as hte original .*
(10:47:36 PM) jsant: navigate away from the page and come back -- it wll remain as .* and not the actual "unset" like it was last updated
(10:49:00 PM) joseph: this is likely just more fallout from putting certain objects in the session
(10:49:18 PM) joseph: the number of jiras for that single class of bug is piling up
(10:51:04 PM) joseph: well, each browser gets it's own session, so since we're stuffing certain objs into the session, each browser won't see the other's change
(10:51:11 PM) joseph: if you log out and back in, i bet you see the update
(10:51:33 PM) joseph: yup - confirmed
Comment 3 Joseph Marques 2009-04-06 07:51:10 EDT
this was fixed indirectly when we moved group resource config and group connection properties to the new configSet JSF component.  this solution calculates the aggregate on the fly using all of the most recent information resource-level config data.  however, this particular bug is rather important to the product, so i'm pushing it through QA (instead of just closing as fixed indirectly).
Comment 4 Jeff Weiss 2009-04-06 15:38:06 EDT
Individual resource's conn props are showing the correct values now.  rev3610
Comment 5 Red Hat Bugzilla 2009-11-10 16:00:01 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-220
This bug relates to RHQ-169

Note You need to log in before you can comment on or make changes to this bug.