Bug 53553 - rpm gives no helpful output when attempting to build without rpm-build
Summary: rpm gives no helpful output when attempting to build without rpm-build
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-11 16:05 UTC by Paul Warren
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-11 16:05:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Warren 2001-09-11 16:05:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
When attempting to build source packages with rpm, rpm simply returns a
usage message if rpm-build is not installed.  There is no error message.

This is poor because the rpm manpage documents the --rebuild options etc.
but makes no reference to the need for rpm-build.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild any-source-package.src.rpm
	

Actual Results:  rpm returns its standard usage message.

Expected Results:  An error message e.g. --rebuild option not available
because...

Additional info:

$ rpm -q rpm
rpm-4.0.2-6x

Comment 1 Jeff Johnson 2001-09-11 16:46:15 UTC
rpm build modes moved to a separate executable, contained
in the rpm-build package, over a year ago.

What's left is legacy. Because of limitations in the
popt exec command, there's no easy and/or obvious way
to get anything other than a usage message if the
rpm-build package is not installed. IMHO, this is as
it should be, because the build modes have moved to
a separate executable, with it's own man page (yes,
the build modes need to be removed from rpm.8), it's own
help message, etc. Expecting the old binary to document
legacy options that are not present is unreasonable.


Note You need to log in before you can comment on or make changes to this bug.