Bug 53555 - install.log: /boot/efi/initrd-2.4.9-0.4smp.img already exists
Summary: install.log: /boot/efi/initrd-2.4.9-0.4smp.img already exists
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: 7.3
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-11 16:49 UTC by Mike McLean
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-19 17:05:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael A. McLean 2001-09-11 16:49:16 UTC
* re0910.0-ia64
* French NFS Full Workstation GUI install

install.log messages:
Installation de kernel-smp.
/boot/efi/initrd-2.4.9-0.4smp.img already exists.
Installation de kernel.
/boot/efi/initrd-2.4.9-0.4.img already exists.

This occurs because autopartitioning does not set /boot/efi to be
reformatted.  Hence the old images are still there.

Comment 1 Matt Wilson 2001-09-12 16:16:43 UTC
/sbin/new-kernel-pkg needs to use mkinitrd -f


Comment 2 Jeremy Katz 2001-09-19 17:03:14 UTC
I was just maintaining what was being used in the kernel %post.  Arjan, was
there a specific reason -f wasn't being used in the kernel %post?

Comment 3 Arjan van de Ven 2001-09-19 17:05:23 UTC
-f is not used to avoid overwriting initrd's that sysadmins carefully
constructed....

Comment 4 Erik Troan 2002-05-21 22:37:10 UTC
I don't think we need to be blowing away things the sysadmin created... /boot/efi
should be formatted; that was the real problem here.

I'm closing this; hopefully anaconda sets the format bit correctly by default
for new installs now. If the users turns that off, this is reasonable behavior,
imho.


Note You need to log in before you can comment on or make changes to this bug.