Bug 535588 - (RHQ-2268) Sub plugin cannot its services into a subcategory from the parent plugin
Sub plugin cannot its services into a subcategory from the parent plugin
Status: CLOSED DUPLICATE of bug 796480
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: RHQ 4.9
Assigned To: Heiko W. Rupp
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-07-24 08:04 EDT by Jean Deruelle
Modified: 2013-07-23 04:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 04:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean Deruelle 2009-07-24 08:04:00 EDT
See Issue in Jopr https://jira.jboss.org/jira/browse/JOPR-188

I moved my Mobicents Sip Servlets jopr plugin (http://code.google.com/p/mobicents/source/browse/trunk/servers/sip-servlets/jopr-plugin) to the latest version of Jopr 2.2 but I ran into a problem 
It seems it doesn't recognize the Applications subcategory from the parent JBoss As plugin 
Here is a snippet of my rhq-plugin.xml 
<service name="Embedded Converged Sip/Web Application (SAR/WAR)" 
subCategory="Applications" 
class="org.rhq.plugins.mobicents.servlet.sip.ConvergedWarComponent" 
discovery="org.rhq.plugins.mobicents.servlet.sip.EmbeddedConvergedWarDiscoveryComponent" 
description="SIP/Web Application embedded inside of an Enterprise Application" 
createDeletePolicy="neither"> 
<runs-inside> 
<parent-resource-type name="JBossAS Server" plugin="JBossAS"/> 
</runs-inside> 

by removing the subCategory="Applications" it works. But the thing end up in the wrong place ie above the Applications branch in the tree on the left hand side of the screen
Comment 1 Red Hat Bugzilla 2009-11-10 16:01:08 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2268
Comment 2 wes hayutin 2010-02-16 11:56:00 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 12:01:07 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Corey Welton 2010-11-22 14:41:27 EST
jsanda - can you look at this in the context of your metadat update work?
Comment 5 John Sanda 2010-11-30 15:50:00 EST
I will go ahead and look into this and report back my findings.
Comment 6 Heiko W. Rupp 2013-07-23 04:48:27 EDT
master e85abcf

"Duplicate" of Bug 796480

*** This bug has been marked as a duplicate of bug 796480 ***

Note You need to log in before you can comment on or make changes to this bug.