Bug 535592 - (RHQ-2271) Excessive Hibernate memory usage by CheckForSuspectedAgentsJob
Excessive Hibernate memory usage by CheckForSuspectedAgentsJob
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: jon30-perf
  Show dependency treegraph
 
Reported: 2009-07-27 15:56 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 16:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-07-27 15:56:00 EDT
Associated case: 316351

The CheckForSuspectedAgentsJob appears to be consuming an excessive amount of memory, mostly in hibernates StatefulPersistenceContext.

Heap dump analysis

org.hibernate.engine.StatefulPersistenceContext (208mb) is being referenced from a thread executing org.rhq.enterprise.server.scheduler.jobs.CheckForSuspectedAgentsJob

Breaking down the 208mb, there is 16mb in the entityEntries member variable, 6mb in the entitiesByKey member variable and 5mb in the proxiesByKey member variable. That leaves around 180mb of what looks like just org.rhq.core.domain.resource.Resource_$$_javassist_50 (and possibly other object) instances. There are ~177,000 objects referenced in the heap dump as being associated with the StatefulPersistenceContext instance, I've only checked the class of  the first 250 of which they are all Resource_$$_javassist_50.

Comment 1 Corey Welton 2009-08-05 13:12:47 EDT
Push to 1.4
Comment 2 Red Hat Bugzilla 2009-11-10 16:01:13 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2271
Comment 3 wes hayutin 2010-02-16 11:57:13 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 4 wes hayutin 2010-02-16 12:02:20 EST
making sure we're not missing any bugs in rhq_triage
Comment 5 Ian Springer 2011-09-06 16:18:15 EDT
It's possible this is related to the SLSB leak issue that was fixed recently (https://bugzilla.redhat.com/show_bug.cgi?id=693232).
Comment 6 Jay Shaughnessy 2013-02-26 16:31:59 EST
This whole mechanism has been reworked since this bug was reported.

Note You need to log in before you can comment on or make changes to this bug.