Bug 535595 - (RHQ-2274) JMX Plugin: format Initial Size and Maximum Size traits in a more user friendly way
JMX Plugin: format Initial Size and Maximum Size traits in a more user friend...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.2
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-07-28 17:18 EDT by Ian Springer
Modified: 2014-05-09 11:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 11:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2009-07-28 17:18:00 EDT
Currently these two traits have values like the following:

Initial Size:  104857600
Maximum Size: 209715200

We should change them to:

Initial Size:  104,857,600 bytes
Maximum Size: 209,715,200 bytes

or even better:

Initial Size:  100.0 MB
Maximum Size: 200.0 MB
Comment 1 Red Hat Bugzilla 2009-11-10 16:01:17 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2274
Comment 2 wes hayutin 2010-02-16 11:56:56 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 12:02:07 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Joseph Marques 2010-11-17 12:31:33 EST
ian, do traits have units?  if not, that's the problem, because all traits are presumed to be strings, and thus don't have an associated formatter.  i suppose adding a new units field for traits would be forward compatible, so that's always an option.
Comment 5 Ian Springer 2010-11-17 12:41:37 EST
No, they don't. We could either go that route, or for a quick one-off fix, have the plugin do the formatting of those two traits itself.

Note You need to log in before you can comment on or make changes to this bug.