Bug 53562 - RFE: DIR_COLORS has some omissions
RFE: DIR_COLORS has some omissions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-11 14:06 EDT by Reuben Thomas
Modified: 2007-03-26 23:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-11 14:06:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Thomas 2001-09-11 14:06:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686; Nav)

Description of problem:
Some file and terminal types are omitted from /etc/DIR_COLORS (I suggest
what reasonable additions might be below).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. N/A
2.
3.
	

Additional info:

Here are my suggestions: add xterms and eterm (as in Emacs term mode) to
the list of supported terminals.

Add the following filetypes:

.img 01;35
.xcf 01;35
.pat 01;35
.gbr 01;35
.ps  01;35 # document formats (magenta)
.eps 01;35
.pdf 01;35
.fig 01;35

and one small thing for consistency: in the comment that says "# image
formats", add " (magenta)" at  the end of the line.
Comment 1 Bernhard Rosenkraenzer 2001-09-18 06:13:48 EDT
Added in 4.1-5, with a couple of changes:
- I've added the KOffice file types to the document types you listed
- I've removed .img from the picture types, it's too confusing because we
  also use .img for disk images (e.g. /boot/initrd-foo.img).


Note You need to log in before you can comment on or make changes to this bug.