Bug 535621 - (RHQ-2298) get CLI to work over SSL
get CLI to work over SSL
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: John Sanda
John Sanda
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks: RHQ-2425
  Show dependency treegraph
 
Reported: 2009-08-06 13:06 EDT by John Mazzitelli
Modified: 2009-11-10 16:22 EST (History)
0 users

See Also:
Fixed In Version: 1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-08-06 13:06:00 EDT
get the CLI to work over SSL.

RemoteClient hardcodes the transport to servlet in init().

It should try sslservlet if the connection fails, because it might be tryign to go over SSL.

We shoud also allow the user to tell us explicitly to use SSL (--secure command line option).
Comment 1 John Mazzitelli 2009-08-07 04:17:37 EDT
refactored lots of cli code to get this to work. now can provide keystore/truststore information to connect to server - you can use it for just encryption but you can also use it for authentication (and you can authenticate cli-to-server as well as the server-to-cli using truststores if you want).

Comment 2 Corey Welton 2009-09-15 00:44:04 EDT
This is on dev's plate.
Comment 3 John Sanda 2009-09-15 10:58:09 EDT
http://jira.rhq-project.org/browse/RHQ-2301 provides more detailed information on this. When invoking the login command as described in RHQ-2301, you can specify the port and transport layer to use as demonstrated below,

rhqadmin@localhost:7080$ login rhqadmin rhqadmin localhost 7443 sslservlet

or 

rhqadmin@localhost:7080$ login rhqadmin rhqadmin localhost 7443

both of the above will result in communication going over port 7443 using the sslservlet transport layer. This can also be done from the rhq-cli(.sh|.bat) start-up script as follows,

$ rhq-cli.sh -u rhqadmin -p rhqadmin -s localhost --port=7443

Note however that you *must* specify the host; otherwise the port argument will be ignored and the default (7080) will be used. This will logged under a separate jira.
Comment 4 John Sanda 2009-09-15 11:03:35 EDT
Opened RHQ-2425 for the issue involving the port value being ignored when the host is not specified with the start up script.
Comment 5 Corey Welton 2009-09-15 11:05:27 EDT
jsanda verified.
Comment 6 Red Hat Bugzilla 2009-11-10 16:01:43 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2298
This bug is duplicated by RHQ-2199

Note You need to log in before you can comment on or make changes to this bug.