Bug 53565 - slogin does not close when last X11 channel is closed
Summary: slogin does not close when last X11 channel is closed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: openssh   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-11 18:30 UTC by Tobias Ringstrom
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-11 18:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tobias Ringstrom 2001-09-11 18:30:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
slogin hangs forever if it is closed (logout) when there is an X11 channel
open, since it does not seem to detect that the last X11 channel has been
cloed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. slogin foo.bar.com
2. xclock &
3. logout          (Shell waits for xclock to close)
4. Close xclock
5. slogin session is not closed as it should be
	

Additional info:

Comment 1 Nalin Dahyabhai 2002-03-07 20:47:51 UTC
This appears to be fixed in 3.1, which is going to be issued as an errata soon,
and will show up in Raw Hide (maybe sooner).


Note You need to log in before you can comment on or make changes to this bug.