Bug 535697 - (RHQ-2366) Excessive Configuration Changes Detected on java.util.Logging resources
Excessive Configuration Changes Detected on java.util.Logging resources
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Greg Hinkle
Corey Welton
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-19 00:19 EDT by Greg Hinkle
Modified: 2009-09-09 14:31 EDT (History)
0 users

See Also:
Fixed In Version: 1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Hinkle 2009-08-19 00:19:00 EDT
Logging resources under the JVM resource type have configuration support that display the currently defined logging categories. The problem is that as more and more code runs in a given JVM it'll initialize more categories. This interacts with the configuration check subsystem to cause an excessive # of changes to be detected. This can have a serious performance impact in very large environments.

To avoid this set of problems we'll have a plugin configuration for the Logging resource type that allows you to enable it configuration facet. It will default to false thus avoiding these detected config changes.
Comment 1 Corey Welton 2009-08-31 09:51:13 EDT
Not sure what we're supposed to be looking at in the UI here to confirm this new config option.
Comment 2 Charles Crouch 2009-08-31 11:09:55 EDT
It will be on the Logging service beneath a JVM Server. You'll want to go to the Connection subtab of the Inventory tab in the UI
Comment 3 Corey Welton 2009-09-09 14:31:39 EDT
QA Verified.
Comment 4 Red Hat Bugzilla 2009-11-10 16:03:00 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2366

Note You need to log in before you can comment on or make changes to this bug.