Bug 535736 - (RHQ-2400) add option to boot server as specific user
add option to boot server as specific user
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Launch Scripts (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
: RHQ-2450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-01 11:22 EDT by Mark Burchard
Modified: 2014-05-09 11:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 11:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Burchard 2009-09-01 11:22:00 EDT
Customer is requesting this.

I actually used to have a script that I modified to do this, but I lost it.  
Comment 1 John Mazzitelli 2009-09-01 12:03:41 EDT
RHQ-1189 did something similar for the agent
Comment 2 Mark Burchard 2009-10-04 13:20:54 EDT
There's no reason for the Server to run as root, which is what it will do when called from init at present. In any case, the runas user should be configurable. Not sure if this should be a wrapper script along the lines of the Agent, but that would at least make things consistent. Syncing the current init scripts style with the EAP jboss_init_* script style would be the "right" way to do it. Something in the "$JBOSS_USER" format. Also, we should move all the configurable variables to a standardized file along the lines of run.conf. Basically, there should be no reason to edit either the Agent or Server start/init scripts at all.

I'm not a big fan of the way the daemon user is configurable in with the Agent at present. It's buried in the file and not very intuitive unless you know *nix. It really should be a variable.
 
Comment 3 Red Hat Bugzilla 2009-11-10 16:03:42 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2400
This bug is related to RHQ-1189
Comment 4 wes hayutin 2010-02-16 12:10:02 EST
mass add of key word FutureFeature to help track
Comment 6 Corey Welton 2010-12-23 09:41:45 EST
Triaged 20-Dec
Comment 7 Corey Welton 2010-12-23 09:47:33 EST
*** Bug 535791 has been marked as a duplicate of this bug. ***
Comment 8 Jay Shaughnessy 2014-05-09 11:48:15 EDT
The RUN_AS stuff should handle this and/or the new rhqctl options.

Note You need to log in before you can comment on or make changes to this bug.