Bug 535766 - (RHQ-2428) argument to ConfigurationManagerBean.scheduleGroupResourceConfigurationUpdate() is XmlAnyType to WsClients.
argument to ConfigurationManagerBean.scheduleGroupResourceConfigurationUpdate...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
Mike Foley
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_spearhead
  Show dependency treegraph
 
Reported: 2009-09-15 14:05 EDT by Simeon Pinder
Modified: 2014-05-09 11:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
All Webservice clients.
Last Closed: 2014-05-09 11:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHQ-2428-patch.txt (4.20 KB, text/plain)
2009-09-18 18:49 EDT, Simeon Pinder
no flags Details

  None (edit)
Description Simeon Pinder 2009-09-15 14:05:00 EDT
One of the arguments to ConfigurationManagerBean.scheduleGroupResourceConfigurationUpdate() is an XmlAnyType.  It looks like the mapping type was not correctly applied during JAXB generation.

Suggested fix is to use an XmlJavaTypeAdapter instance on server side to return an equivalent JAXB serializable type consumable by webservice clients.  This may require WS scope only annotations being added to core/domain types to achieve successful serialization.  No other changes to core/domain types are anticipated. 
Comment 1 Simeon Pinder 2009-09-18 18:10:14 EDT
In release discussions with Joe about this issue, it was pushed to be fixed in post 2.3.  
Comment 2 Simeon Pinder 2009-09-18 18:27:22 EDT
Impact to Users:
For all WS clients they will not have a way to schedule GroupResourceConfiguration updates from the Web Service interface alone.  The type exposed to them is too vague.  This will be fixed in a subsequent release.

The suggested workaround is to use the cli to schedule GroupResourceConfiguration updates remotely or to do that update by the Jon UI. 
Comment 3 Simeon Pinder 2009-09-18 18:49:52 EDT
This makes the parameters more explicit. Still need to add unit test code for this. This is still a TODO:
Comment 4 Red Hat Bugzilla 2009-11-10 16:04:16 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2428
Imported an attachment (id=368798)
Comment 5 wes hayutin 2010-02-16 11:54:17 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 6 wes hayutin 2010-02-16 11:59:35 EST
making sure we're not missing any bugs in rhq_triage
Comment 7 Jay Shaughnessy 2014-05-09 11:50:56 EDT
WS are gone.

Note You need to log in before you can comment on or make changes to this bug.