Bug 53577 - Up2date hangs when wiev advisory pressed
Summary: Up2date hangs when wiev advisory pressed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-12 08:30 UTC by Ola P. O.
Modified: 2015-01-07 23:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 20:06:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ola P. O. 2001-09-12 08:30:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i586)

Description of problem:
My best guess is that the connection was bad. And up2date couldn't handle
it.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Start up2date
2. Mark a package
3. Click 'Wiev Advisory'
	

Actual Results:  It hangs! The watch-pointer is shown.



Expected Results:  I should see the Advise...

Additional info:

version: up2date-2.5.4-1
I'm on a 10mbit connection to internet.

 Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/up2date/gui.py", line 193, in showAdvisory
    advisories = up2date.getAdvisoryInfo(rowData[1])
  File "/usr/share/rhn/up2date/up2date.py", line 1222, in getAdvisoryInfo
    getVersion())
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 608, in
__call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 658, in
__request
    self.__password
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 567, in
request
    headers, fd = req.send_http(host, proxy, handler, self.__type)
  File "/usr/lib/python1.5/site-packages/cgiwrap.py", line 461, in
send_http
    h = myHTTPS(host, port, self.__ca_chain)
  File "/usr/lib/python1.5/site-packages/cgiwrap.py", line 130, in __init__
    httplib.HTTPS.__init__(self, host, port, cachain)
  File "/usr/lib/python1.5/httplib.py", line 214, in __init__
    HTTP.__init__(self, host, port)
  File "/usr/lib/python1.5/httplib.py", line 53, in __init__
    if host: self.connect(host, port)
  File "/usr/lib/python1.5/site-packages/cgiwrap.py", line 165, in connect
    sock.connect(host, port)
socket.error: (113, 'No route to host')

Comment 1 Adrian Likins 2001-12-03 20:06:38 UTC
I havent been able to duplicate this.

rhnQA, can you try to duplicate this?

Comment 2 Adrian Likins 2002-03-26 23:34:30 UTC
This looks like a network error to me, and I havent seen any 
similar reports in a long time, so I am closing this bug out.


Note You need to log in before you can comment on or make changes to this bug.