Bug 535771 - (RHQ-2432) Plugin build system should not include anything in the compile time classpath that is not also going to be there at runtime.
Plugin build system should not include anything in the compile time classpath...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Build System (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 00:03 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 11:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-09-16 00:03:00 EDT
We need to split up our projects in such a way that its possible to prevent the issue in https://jira.jboss.org/jira/browse/JOPR-381 from occurring again, i.e. the plugin should not compile if it references an api that won't be available at runtime.
Comment 1 John Mazzitelli 2009-09-16 01:10:19 EDT
this specific case was because somehow the Jopr JBossAS 4/5 pom's had a compile time dep on clientapi module (it should have just been a test dependency).
Comment 2 Ian Springer 2009-09-16 08:05:17 EDT
It is a mystery as to how was the common/jboss-as module even compiling with the references to client-api StringUtil. According to "mvn dependency:tree", the only dep on the client-api.jar was in test scope, so it should not have even been in the javac classpath. looks like a Maven bug to me...

C:\Projects\jopr-trunk\modules\common\jboss-as>mvn dependency:tree
[INFO] Scanning for projects...
[WARNING]
        Profile with id: 'embedded' has not been activated.

[INFO] Searching repository for plugin with prefix: 'dependency'.
[INFO] org.rhq: checking for updates from jboss
[INFO] org.apache.maven.plugins: checking for updates from jboss
[INFO] org.codehaus.mojo: checking for updates from jboss
[INFO] ------------------------------------------------------------------------
[INFO] Building Jopr JBossAS 4/5 Plugins Common Library
[INFO]    task-segment: [dependency:tree]
[INFO] ------------------------------------------------------------------------
[INFO] [dependency:tree {execution: default-cli}]
[INFO] org.jboss.on:jopr-jboss-as-common:jar:2.3.0-SNAPSHOT
[INFO] +- ant:ant:jar:1.6.5:compile
[INFO] +- jboss:jbpm:jar:3.1.1:compile
[INFO] +- dom4j:dom4j:jar:1.6.1:compile
[INFO] |  \- xml-apis:xml-apis:jar:1.0.b2:compile
[INFO] +- org.rhq:rhq-core-util:jar:1.3.0-SNAPSHOT:provided
[INFO] |  \- jdom:jdom:jar:1.0:provided
[INFO] +- org.rhq:rhq-core-domain:jar:1.3.0-SNAPSHOT:provided
[INFO] +- org.rhq:rhq-core-plugin-api:jar:1.3.0-SNAPSHOT:provided
[INFO] +- org.rhq:rhq-core-native-system:jar:1.3.0-SNAPSHOT:provided
[INFO] |  +- org.hyperic:sigar:jar:1.6.3.82:provided
[INFO] |  \- org.hyperic:sigar-dist:zip:1.6.3.82:provided
[INFO] +- org.rhq:rhq-core-plugin-container:jar:1.3.0-SNAPSHOT:test
[INFO] |  +- org.rhq:rhq-core-comm-api:jar:1.3.0-SNAPSHOT:test
*** [INFO] |  \- org.rhq:rhq-core-client-api:jar:1.3.0-SNAPSHOT:test ***
[INFO] +- javax.xml.bind:jaxb-api:jar:2.1:provided
[INFO] |  +- javax.xml.stream:stax-api:jar:1.0-2:provided
[INFO] |  \- javax.activation:activation:jar:1.1:provided
[INFO] +- com.sun.xml.bind:jaxb-impl:jar:2.1.6:provided
[INFO] +- javax.persistence:persistence-api:jar:1.0:provided
[INFO] +- jboss.jboss-embeddable-ejb3:hibernate-all:jar:1.0.0.Alpha9:provided
[INFO] +- commons-logging:commons-logging:jar:1.1.0.jboss:provided
[INFO] +- i18nlog:i18nlog:jar:1.0.9:compile
[INFO] +- log4j:log4j:jar:1.2.14:provided
[INFO] +- org.testng:testng:jar:jdk15:5.9:test
[INFO] |  \- junit:junit:jar:3.8.1:test
[INFO] \- org.jetbrains:annotations:jar:7.0.2:provided
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 20 seconds
[INFO] Finished at: Tue Sep 15 22:21:08 EDT 2009
[INFO] Final Memory: 21M/127M
[INFO] ------------------------------------------------------------------------
Comment 3 Red Hat Bugzilla 2009-11-10 16:04:21 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2432
Comment 4 wes hayutin 2010-02-16 12:10:08 EST
mass add of key word FutureFeature to help track
Comment 5 Corey Welton 2010-08-30 13:40:38 EDT
Ian, do we still see this w/ the latest maven?  If not, let's close.

Note You need to log in before you can comment on or make changes to this bug.