Bug 535832 - (RHQ-2488) JBoss-AS Plugin: pooled Invoker in jboss 4.0.5 if used in the jmx invoker causes weird class cast exception
JBoss-AS Plugin: pooled Invoker in jboss 4.0.5 if used in the jmx invoker cau...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.3
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-11-04 21:44 EST by Andrew C. Oliver
Modified: 2013-12-07 10:40 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
AIX J9 JDK1.5 JBoss 4.0.5
Last Closed: 2013-12-07 10:40:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew C. Oliver 2009-11-04 21:44:00 EST
from the agent:

java.lang.ClassCastException: javax.management.ObjectName incompatible with javax.management.ObjectName
        at org.mc4j.ems.impl.jmx.connection.DConnection.loadSynchronous(DConnection.java:147)
        at org.rhq.plugins.jbossas.JBossASServerComponent.loadConnection(JBossASServerComponent.java:1
030)
        at org.rhq.plugins.jbossas.JBossASServerComponent.start(JBossASServerComponent.java:237)
        at sun.reflect.GeneratedMethodAccessor28.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:618)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContaine
r.java:525)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:284)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
        at java.lang.Thread.run(Thread.java:810)

Switching back to the straight jrmp invoker unpukes this.

(let me know if this is jopr, I'm not real clear on the beginning and end of each)
Comment 1 Andrew C. Oliver 2009-11-06 09:46:05 EST
Btw the reason that is important is in these releases of jbas some pretty ugly bugs prevent you from changing the bind address of the invoker without changing the bind address for all of jboss (meaning it tries to hit the ethernet).
Comment 2 Andrew C. Oliver 2009-11-06 09:47:08 EST
..where the pooled invoker obeys and plays nice.  I blame bill burke...whether he coded that or not.
Comment 3 Red Hat Bugzilla 2009-11-10 16:05:23 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2488
Comment 4 wes hayutin 2010-02-16 11:59:09 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 5 wes hayutin 2010-02-16 12:03:57 EST
making sure we're not missing any bugs in rhq_triage
Comment 6 Corey Welton 2010-10-06 23:32:44 EDT
Triaged 5-Oct

Note You need to log in before you can comment on or make changes to this bug.