Bug 53586 - RH7.2 RC2 Kernel Panics with Dual Ch wide ultra 3 controller and embedded scsi controller
RH7.2 RC2 Kernel Panics with Dual Ch wide ultra 3 controller and embedded scs...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-12 08:50 EDT by Bryan Leopard
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-28 14:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested grub.conf and map files (600 bytes, text/plain)
2001-09-26 16:06 EDT, chadd hudson
no flags Details
more grub and conf files (602 bytes, application/octet-stream)
2001-10-10 15:13 EDT, chadd hudson
no flags Details
Attached map and conf files to this reply (602 bytes, text/plain)
2001-11-02 15:59 EST, chadd hudson
no flags Details
initrd.img (474.13 KB, patch)
2001-11-28 14:00 EST, chadd hudson
no flags Details | Diff

  None (edit)
Description Bryan Leopard 2001-09-12 08:50:13 EDT
System:
ML530
P19 4-10-01
(2) 1.0ghz proc
128mbr
NC3122 nic in slot 1
64bit 66mhz dual ch wide ultra 3 scsi controller (firmware v2.252) in slot 
6
embedded scsi port 1 as boot controller

drive configuration all formated with ext3 filesystem:
3 drives on internal scsi
sda1 - 30mb /boot (active)
sdb1 - 9gb /disk1
sdc1 - 9gb /disk2

3 drives in ext. storage box off 64 bit scsi controller
sdd1 - 9 gb /disk 3
sde1 - 9 gb /disk 4
sdf1 - 256mb swap
sdf2 -  17 gb /

I performed a full install with grub selected as the boot loader.

Last 7 lines on screen during boot just after install:
mounting /proc filesystem
creating root device
mounting root filesystem
mount: error 6 mounting ext3
pivotroot: pivot_root (/sysroot, /sysroot/initrd) failed: 2
freeing unused kernel memory: 240k freed 
Kernel panic: no init found. Try passing init= option to kernel
Comment 1 Michael Fulbright 2001-09-12 12:38:50 EDT
Is this a known kernel issue?
Comment 2 Arjan van de Ven 2001-09-12 12:43:49 EDT
doubt it; last time I saw this was that mkinitrd didn't put the module for the /
device in the initrd ..... the kernel tells you to "go away" when you try to
mount /... and then the kernel says "but you don't have /sbin/init, please fix"
Comment 3 Matt Wilson 2001-09-13 10:51:16 EDT
yes, error 6 is "No such device or address".  It looks like the initrd didn't
load the module.

This system needs to be booted into rescue mode and the initrd copied off and
attached to the bug.  Also attach /boot/grub/grub.conf.
Comment 4 chadd hudson 2001-09-18 11:43:29 EDT
I reproduced the issue with RH7.2 GMRC and found the same result.  I cannot 
successfully load from the rescue floppy made during install.  When I do, it 
states to wait 10seconds and it will boot from /dev/sdf1 (where / is).  If I 
enter linux/dev/sda1 (where /boot is) it still kernel panics.  I even tried 
entering linux /dev/sdf2 and found the same result.  

Additional info:  I selected to have the kernel installed to the boot partition 
during the install.  I basicaly have /boot on my rimary controller and 
everything else thru a standup scsi controller connected to an external storage 
box.  I cannot find if this is a known limitation of grub.
Comment 5 chadd hudson 2001-09-18 11:46:56 EDT
Correction to last statement:  Within first paragraph should state that "When I 
do, it states to wait 10 seconds and it will boot from /dev/sdf2 (where / is)."
Comment 6 Bill Nottingham 2001-09-26 11:19:07 EDT
Please attach the requested files.
Comment 7 chadd hudson 2001-09-26 16:06:27 EDT
Created attachment 32679 [details]
requested grub.conf and map files
Comment 8 Jeremy Katz 2001-10-04 12:39:52 EDT
Can you try using the boot.img or bootnet.img at
http://people.redhat.com/~katzj/compaq/ with the 7.2 respin and see if that
fixes this problem?
Comment 9 chadd hudson 2001-10-09 14:08:10 EDT
I tried both the boot.img and bootnet.img found at 
http://people.redhat.com/~katzj/compaq/ .  I used RH 7.2 Enigma GM respin for 
my re-test and found that it didn't solve the problem.  I used rawrite.exe to 
make a diskette with the image I donloaded and attempted to boot from it.  On 
both instances I found the message:
boot:
Loading:
Could not find ramdisk.img: initrd.img
boot:
boot failed pleas change disks and press a key.
Comment 10 Jeremy Katz 2001-10-09 16:32:07 EDT
*sigh*  sorry, typos in copying updated files to the images.  Updated the images
that are there if you could try again
Comment 11 chadd hudson 2001-10-10 15:13:49 EDT
Created attachment 33802 [details]
more grub and conf files
Comment 12 chadd hudson 2001-10-10 15:14:28 EDT
The first time I tried with the new boot.img diskette resulted in the system 
booting into the Compaq system partition I had created during Smart Start.  I 
specificly instructed for GRUB to be written to the /boot partiton (sda1).  I 
then removed all compaq system partitions and then performed the install.  
After the reboot (end of install) I found the message "Missing operating 
system". If I use the boot disk made during install I find the same result as 
the first post (above 9/12/01 8:50).  I booted with the cd and copied the conf 
and mpa files if you need them.  Attachment is zipped2.zip.
Comment 13 Jeremy Katz 2001-10-19 16:23:44 EDT
Argh, okay... even newer disks there, dated today with the following md5sums

69bbc607aec98f4cf0118eb4128ac6aa  boot.img
37b695e4264d38dabe0050af32294d2e  bootnet.img

If you could try these, that would be great and I think they should finally,
hopefully, do the right thing.
Comment 14 Brent Fox 2001-10-25 10:41:22 EDT
chadd.hudson, any progress here?
Comment 15 chadd hudson 2001-11-02 15:59:11 EST
Created attachment 36261 [details]
Attached map and conf files to this reply
Comment 16 chadd hudson 2001-11-02 16:00:21 EST
I tried the latest boot.img to start the install and install the system.  This 
time I was using RH7.2 enigma-respin.  I am having the same result as before 
(post 2001-10-10 15:14:28). I am having the kernal installed to the boot 
partition as before and it's booting into the system partition.  The good news 
at least is that if I use the boot diskette made at the end of the install I 
can get into the system.  The reason we need this system to use the boot 
partition is that we need the F10 to boot into the system partition.  If I 
write to the MBR then F10 will still boot into Linux.

I posted the map and conf files above in zipped3.zip
Comment 17 Jeremy Katz 2001-11-27 15:39:31 EST
Are the different controllers using different drivers?   During the boot-up, are
the SCSI controllers recognized and the drives then recognized?  Also, can you
attach the initrd?
Comment 18 chadd hudson 2001-11-28 13:58:51 EST
Yes the two different controllers are using different drivers.  The embedded 
scsi is an LSI chipset (symbios 53c8xx driver) and the stand up card is an 
adaptec chipset (aic78xx driver).  During boot up the drives and controllers 
are all accounted for. I will attach the initrd.img. I also noticed that this 
is posting to the Pensacola Devel Whiteboard.  I am using the enigma-respin if 
it matters.
Comment 19 chadd hudson 2001-11-28 14:00:15 EST
Created attachment 38964 [details]
initrd.img
Comment 20 Jeremy Katz 2002-01-21 20:18:27 EST
Errata currently in testing should fix this.  Please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.