Bug 53597 - mount prepends current working directory to nfs mounts in mtab
mount prepends current working directory to nfs mounts in mtab
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-12 12:04 EDT by Tom "spot" Callaway
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-12 12:04:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2001-09-12 12:04:19 EDT
Description of Problem:

When mounting a filesystem from a remote node via NFS, mount corrupts
/etc/mtab by prepending the current working directory (from which the mount
command was run). This corrupt entry is then reported by df and mount when
displaying information on the mounted filesystem. 


Version-Release number of selected component (if applicable):
mount: mount-2.11e

How Reproducible:

Always.

Steps to Reproduce:
[root@newt /root]# mount -r decatl:/usr/dec /mnt 
[root@newt /root]# df 
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda3              8325288   1349872   6552508  18% /
/dev/sda1               101093      6875     88997   8% /boot
/root/decatl:/usr/dec  4000000   2610040   1389960  66% /mnt

Notice the leading "/root/".

The corruption is in /etc/mtab, which shows the following entry for decatl:
/root/decatl:/usr/dec /mnt nfs ro,addr=16.113.7.95 0 0

/proc/mounts is fine, showing the following:

decatl:/usr/dec /mnt nfs
ro,v3,rsize=8192,wsize=8192,hard,udp,lock,addr=decatcl 0

/etc/mtab should have:

decatl:/usr/dec /mnt nfs rw,addr=16.113.7.95 0 0

This is fixed in util-linux 2.11f-9 (current rawhide for alpha), mount
version 2.11g. Perhaps this RPM should be pushed as errata for alpha?

Workaround fix: Use util-linux 2.11f-9 from rawhide.

Note: This bug was sent through Compaq Support instead of being filed
directly, and was filed by Red Hat Support. Compaq would like to see this
pushed as an official errata.
Comment 1 Elliot Lee 2002-01-04 13:38:59 EST
Newer util-linux packages have since (coincidentally) been pushed as errata.

Note You need to log in before you can comment on or make changes to this bug.