Bug 535973 - (RHQ-372) Uninventory button should not be displayed for Services
Uninventory button should not be displayed for Services
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
0.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 12:34 EDT by Ian Springer
Modified: 2014-11-09 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-04-24 12:34:00 EDT
If a Service is uninventoried, it will be rediscovered on the next Service scan and auto-imported by the Server. The auto-import of Services is by design, but it has the side effect of making uninventorying Services rather pointless. So it would be less confusing for users to not even provide the option to uninventory Services. On the Browse Resources page, this would mean not displaying an Uninventory button when viewing Services. On the Inventory tab's Child Resources section, it would mean not displaying the Uninventory button if all child Resources are Services. In the case where there is a mix of Server and Service child Resources, the button would have to be shown for the sake of the Servers.
Comment 1 Jason Dobies 2008-04-24 14:27:04 EDT
What happens now if they uninventory a service? Does it get uninventoried successfully and then silently appear on the next discovery?

If that's the case, I'd argue this should be higher than a minor bug. I think it's going to be confusing and frustrating to the user if we give them the ability to uninventory a service and then repeatedly ignore their wishes by re-adding it on each discovery.
Comment 2 Heiko W. Rupp 2008-04-29 08:41:46 EDT
I rather think we should have an "uninventory and ignore" button, that uninventories the service and leaves it as ignored in the resource tree, so that it won't get autodiscovered.

On my Mac I have 4 network interfaces, of which at least one is always administratively down. I want to get rid of this in the inventory and not having it showing red in half of the application.
Comment 3 Joseph Marques 2008-07-20 17:25:35 EDT
on the one hand, "uninventory and ignore" makes sense; on the other hand, the system today does not allow ignoring services yet.  this still needs more discussion.
Comment 4 Joseph Marques 2008-12-17 21:48:52 EST
rev2438 - suppress univentory button for services, since they get automatically rediscovered; 
Comment 5 Jeff Weiss 2009-01-05 15:42:15 EST
Verified, rev2522.  no "uninventory" button for services.  Still there for platforms and servers.
Comment 6 Red Hat Bugzilla 2009-11-10 16:07:57 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-372
This bug is related to RHQ-910
This bug relates to RHQ-618

Note You need to log in before you can comment on or make changes to this bug.