This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535976 - (RHQ-375) Improve handling of groups with mixed availability (like config update)
Improve handling of groups with mixed availability (like config update)
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
1.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 17:23 EDT by Jay Shaughnessy
Modified: 2009-02-23 21:46 EST (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Any
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2008-04-24 17:23:00 EDT
If I create a compatible group of resources I can then manipulate group members in various ways because they have the same resource type.  As an example,  performing a plugin config update for a group of JBAS servers, setting the shutdown method.

If I attempt to do this when one or more of the resources is unavailable it will almost certainly fail.  The failure generates a massive stack trace, displayed in the update detail for the failure, that I think boils down to the resource being unavailable (is this is specific to JBAS servers?).  Also, it can cause a long "in-progress" state for the update.

Perhaps the user should be warned before, or prevented from, performing certain manipulations on groups with mixed availability.
Comment 1 Joseph Marques 2009-02-04 17:28:04 EST
we should talk about how to visually / verbally tell the user what's going on here for 1.2
Comment 2 Jay Shaughnessy 2009-02-23 21:46:15 EST
Although there may still be some weaknesses here the overall mechanism is much improved with asynch update execution and lots of othr improvements to config update.  Let's close this and defer to other, future jiras, if any.
Comment 3 Red Hat Bugzilla 2009-11-10 16:08:00 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-375

Note You need to log in before you can comment on or make changes to this bug.