Bug 53598 - Xconfigurator fails to probe memory size
Summary: Xconfigurator fails to probe memory size
Status: CLOSED DUPLICATE of bug 39745
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-12 16:09 UTC by Peter Fales
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 05:26:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Fales 2001-09-12 16:09:42 UTC
Description of Problem:

We had a system where Xconfigurator fails to probe the graphics memory
size.    The system
is an IBM thinkpad, but I suspect the same problem could show up
elsewhere.    I did some 
investigating with gdb, and the problem seems to be that the probe results
in the following line from
the server:

(--) R128(0): VideoRAM: 16384 kByte (128-bit SDR SGRAM 1:1)

Since Xconfigurator looks for the field following the rightmost ':'
character, it gets "1" instead of 16384


How Reproducible:

Always



Steps to Reproduce:
1.  Run Xconfigurator 
2.  Allow it to probe memory size


Actual Results:

Probe fails

Expected Results:

Should have reported 16MB

Additional Information:

Comment 1 Mike A. Harris 2001-09-13 05:26:01 UTC
I think this bug has been fixed already in later releases.. will have
to doublecheck and confirm however...

Comment 2 Mike A. Harris 2002-05-30 22:13:58 UTC
Different card, but same problem as another report.  Closing as dupe, so
both issues - if still present can be investigated at the same time and
fixed together.

*** This bug has been marked as a duplicate of 39745 ***


Note You need to log in before you can comment on or make changes to this bug.