Bug 535995 - (RHQ-392) Configuration rendering of non-required enumerated values is misleading
Configuration rendering of non-required enumerated values is misleading
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2008-04-29 11:15 EDT by Jason Dobies
Modified: 2011-02-17 15:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 15:20:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Dobies 2008-04-29 11:15:00 EDT
With the following description:

            <c:simple-property name="shutdownMethod" displayName="Shutdown Method" type="string" required="false" default="JMX" 
                               description="The method used to execute the Shutdown operation;
                                            defaults to 'JMX MBean'.">
                <c:property-options>
                   <c:option value="JMX"    name="JMX MBean" default="true"/>
                   <c:option value="SCRIPT" name="shutdown script"/>
                </c:property-options>                    
            </c:simple-property>                                            

I'd expect checkboxes since required is false, however radio buttons are rendered. This forces the user into a choice even though it's not required (unset is also not checked by default).
Comment 1 Red Hat Bugzilla 2009-11-10 16:08:21 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-392

Note You need to log in before you can comment on or make changes to this bug.