This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 536072 - (RHQ-461) add support for .child
add support for .child
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubTask
Depends On:
Blocks: RHQ-399
  Show dependency treegraph
 
Reported: 2008-05-12 15:56 EDT by Jessica Sant
Modified: 2014-11-09 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
JON 2.0 GA
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jessica Sant 2008-05-12 15:56:00 EDT
Customer has 100 application servers, 50 of them have a web app deployed called "blah.war" -- they need to create a group of all appservers that have that webapp deployed.

(this is related to support issue # 179757)
Comment 1 Joseph Marques 2008-05-12 23:04:12 EDT
rev818 - support ".child" expression token; 
Comment 2 Joseph Marques 2008-06-16 14:36:02 EDT
to create this group, use the following expression:

resource.type.plugin = JBossAS
resource.type.name = JBossAS Server
resource.child.name.contains = blah.war 
Comment 3 Jeff Weiss 2008-06-16 14:50:53 EDT
This works now (qa-6020), I tried 

resource.type.plugin = JBossAS
resource.type.name = JBossAS Server
resource.child.name.contains = rhq

and it matches my rhq instance but not my AS 4.0.4 server.
Comment 4 Red Hat Bugzilla 2009-11-10 16:09:46 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-461

Note You need to log in before you can comment on or make changes to this bug.