Bug 53613 - XFree86 4.1.0 ATI r128 driver hangs with M3 behind PCI bridge
Summary: XFree86 4.1.0 ATI r128 driver hangs with M3 behind PCI bridge
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-12 21:24 UTC by John Klingler
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-09 15:20:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compile info, stack trace (ddd), XF86Config config file and xdm-error log (21.94 KB, text/plain)
2001-09-12 21:29 UTC, John Klingler
no flags Details

Description John Klingler 2001-09-12 21:24:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22smp i686)

Description of problem:
If an ATI Rage 128 Mobility LE has a PCI bridge between it and the main PCI
bus,  the
XFree86 4.1.0  r128 driver will hang when moving windows. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a PCI Card containing multiple Rage 128 LE (M3) accelerators and
PCI  
   bridge  (DEC DC21152 rev 3))
2. Boot roswell (2.4.1_SMP)
3. Configure XF86Config for multiple screens
4. Configure /usr/lib/X11/xdm/Xservers to run XFree86 4.1.0 with +xinerama
option
5. start xdm
6. configure desktop to show contents when moving windows
7. open a window, e.g. an xterm
8. move the window back and forth across screens
	
Actual Results:  The system is hung. You can ping it but not rlogin.
Control+Alt+Del does not work. Exported nfs file systems cannot be accessed
(request hangs). before hanging, moving window leaves artifacts on root
window.

Comment 1 John Klingler 2001-09-12 21:29:53 UTC
Created attachment 31697 [details]
compile info, stack trace (ddd), XF86Config config file and xdm-error log

Comment 2 Mike A. Harris 2001-09-13 05:32:41 UTC
Just to clarify... You are running a Roswell, or Roswell 2 system?
What specific set of XFree86 RPM packages (or do all releases you've tried),
cause this behaviour?

Comment 3 Mike A. Harris 2001-09-13 05:34:15 UTC
BTW, what kernel were you running this under?

Comment 4 John Klingler 2001-09-13 20:15:47 UTC
Redhat Version =  Roswell (7.2 beta),  kernel = 2.4.6 (correction), 
XFree86-4.1.0-0.9.4.i386.rpm
Prior releases of XFree86 did not work at all because the "CRT" option was not
supported for
the Rage 128 Mobility (flat panel only). 

The source code that I used when problems arose with the installed XFree86 was a
tarball, 
X410src-1.tgz. I also tested this on Guinness 7.0 running 2.2.16-22smp. Same
problem. 

If you do not have a multi-headed M3 adapter, I will send you one. 


Comment 5 Mike A. Harris 2002-02-09 15:18:54 UTC
If you haven't already, could you please upgrade to our latest release
of XFree86, and relevant erratum of version 4.1.0-15.  I don't
know if the problem you have encountered is fixed in it or not, but
it is worth trying before proceeding with further troubleshooting.

make sure you've got our latest kernel update also.

Comment 6 Mike A. Harris 2002-02-09 15:20:26 UTC
Sheesh, I forgot to mention also that XFree86 4.2.0 is in rawhide and may
solve this problem for you if 4.1.0-15 does not, if you're willing to give
it a shot.  Either way, update me on your current status and we'll see what
we can do.

Comment 7 Mike A. Harris 2002-07-26 16:24:41 UTC
I haven't heard back on this since my last comment so I am assuming the
bug is no longer present in Red Hat Linux 7.3 with XFree86 4.2.0.

If the problem does however still exist, please reopen the bug report,
and let me know the current status.  Include a new log and config file
as file attachments if and when you reopen.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.