Bug 536163 - (RHQ-542) have Server support running on Java (JRE or JDK) 6
have Server support running on Java (JRE or JDK) 6
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Build System (Show other bugs)
1.0
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 18:29 EDT by Ian Springer
Modified: 2014-11-09 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-06-04 18:29:00 EDT
A few reasons to do this:

1) Java 6 has improved performance
2) Java 5 is being obsoleted by Sun soon
3) it gives customers more flexibility

The following page describes how to get AS 4.2 running on Java 6: http://thesmallpotato.blogspot.com/2007/06/jdk-16-jboss-420-ejb3-web-service-axis2.html

Also, according to Greg, an upcoming CP for AS is supposed to add "official" support for Java 6 - he thinks next month.
Comment 1 Ian Springer 2008-06-05 17:23:20 EDT
Done - r940.

The container's jbossas dir was modified as follows:

1) move jaxb-api.jar, jaxb-impl.jar, jboss-jaxrpc.jar, jboss-jaxws.jar, and jboss-saaj.jar from server/default/deploy/jbossws.sar/ to lib/endorsed/
2) move activation.jar from server/default/lib to lib/endorsed/
3) delete xalan.jar from lib/endorsed/; this was necessary to work around the following Java 6 bug: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6519088 (see also http://jira.jboss.org/jira/browse/JBAS-2073)


Comment 2 Jeff Weiss 2008-06-11 10:41:18 EDT
This defect was accidentally marked 'qa in progress', pushing back to resolved.
Comment 3 Jeff Weiss 2008-06-12 09:23:49 EDT
I started the agent and server under sun jdk6u6, and then ran the automated UI regression suite, which passed.

I will continue to run other tests under java 6 and open any issues I find.
Comment 4 Jeff Weiss 2008-06-12 10:12:08 EDT
I ran the automation on all four combos (serv/agent, 1.5/1.6), all passed.
Comment 5 Jeff Weiss 2008-09-30 16:28:53 EDT
I think we've tested this enough, I've done most of my 1.1 testing on java 6, and haven't seen any jdk related problems.
Comment 6 John Mazzitelli 2009-09-02 15:56:59 EDT
I'm running on this:

java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot(TM) Client VM (build 10.0-b23, mixed mode, sharing)

and I get this at startup:

2009-09-02 15:31:17,700 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/]] Servlet  threw load() exception
java.lang.IllegalArgumentException: Not supported: indent-number
	at org.apache.xalan.processor.TransformerFactoryImpl.setAttribute(TransformerFactoryImpl.java:576)
	at java.util.prefs.XmlSupport.writeDoc(XmlSupport.java:247)
	at java.util.prefs.XmlSupport.export(XmlSupport.java:106)
	at java.util.prefs.AbstractPreferences.exportSubtree(AbstractPreferences.java:1596)
	at org.rhq.enterprise.server.core.comm.ServerCommunicationsService.loadConfigurationFile(ServerCommunicationsService.java:912)
	at org.rhq.enterprise.server.core.comm.ServerCommunicationsService.prepareConfigurationPreferences(ServerCommunicationsService.java:790)
	at org.rhq.enterprise.server.core.comm.ServerCommunicationsService.reloadConfiguration(ServerCommunicationsService.java:339)
	at org.rhq.enterprise.server.core.comm.ServerCommunicationsService.startCommunicationServices(ServerCommunicationsService.java:192)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
	at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
	at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
	at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
	at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
	at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:288)
	at $Proxy438.startCommunicationServices(Unknown Source)
	at org.rhq.enterprise.gui.startup.StartupServlet.startServerCommunicationServices(StartupServlet.java:260)
	at org.rhq.enterprise.gui.startup.StartupServlet.init(StartupServlet.java:118)
	at javax.servlet.GenericServlet.init(GenericServlet.java:212)
Comment 7 John Mazzitelli 2009-09-02 15:57:30 EDT
BTW: I tried putting serializer/xalan jars, v2.7.1, in jbossas/lib/endorsed (removing the old jars) and it still didn't work
Comment 8 Red Hat Bugzilla 2009-11-10 16:11:29 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-542
This bug relates to RHQ-3
This bug relates to RHQ-2065

Note You need to log in before you can comment on or make changes to this bug.