Bug 536181 - (RHQ-559) new service misses its initial collection interval
new service misses its initial collection interval
Status: CLOSED DUPLICATE of bug 751231
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks: jon30-bugs
  Show dependency treegraph
 
Reported: 2008-06-10 13:11 EDT by John Mazzitelli
Modified: 2011-11-16 13:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-16 13:19:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-06-10 13:11:00 EDT
(1:03:06 PM) mazz: I have a service - it has a measurement trait defined.  the trait has a collection interval of 86400000 (1 day)
(1:03:21 PM) mazz: that service has a parent server - also with a trait with the same interval
(1:03:38 PM) mazz: the parent server gets its trait collected fine - as soon as I import, I can see its value
(1:03:57 PM) mazz: BUT! the service's trait is never collected.  I have a breakpoint in my getValue() method of my plugin component and its never called
(1:04:17 PM) mazz: if I change the interval via the UI to 1 minute, I see it called and the trait is collected fine and I see it in the UI afterwards.
(1:04:53 PM) mazz: so it seems the initial committing of the service doesn't trigger a collection - I bet it'll show up after 1 day passes and the collection interval triggers
(1:05:55 PM) mazz: may or may not be related to : http://jira.rhq-project.org/browse/RHQ-255
(1:08:34 PM) ghinkle: yea mazz, i've seen that
(1:08:43 PM) ghinkle: never figured out why it was happening
(1:08:52 PM) ghinkle: it just misses the first interval
(1:08:59 PM) mazz: right -that's what it looks like to me
Comment 1 Red Hat Bugzilla 2009-11-10 16:11:54 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-559
Comment 2 wes hayutin 2010-02-16 16:09:59 EST
Mass move to component = Monitoring
Comment 3 John Mazzitelli 2011-11-16 13:19:40 EST
see bug #751231 - this same thing was fixed and verified.

*** This bug has been marked as a duplicate of bug 751231 ***

Note You need to log in before you can comment on or make changes to this bug.