Bug 53620 - arts package does not install artswrapper with setuid
arts package does not install artswrapper with setuid
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 01:07 EDT by A. Miklas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 01:07:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Miklas 2001-09-13 01:07:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-12 i686; en-US; 0.7)
Gecko/20010316

Description of problem:
The file /usr/bin/artswrapper is not installed with the setuid root
permission.  The "aRts control" utility indicates that this is a
requirement for smooth audio playback.  Additionally, because the file is
not setuid, some options in the KDE control center for "sound server" have
no effect.

This file should probably be installed setuid.


Version-Release number of selected component (if applicable):
arts-2.1.2-1

How reproducible:
Always

Steps to Reproduce:
N/A
	

Additional info:

This bug was filed under component kdelibs because I couldn't find an arts
option instead.
Comment 1 Bernhard Rosenkraenzer 2001-09-13 04:29:45 EDT
This was intentional because artswrapper did not have a security audit in the 
7.1 timeframe.
It was audited for 7.2, and it is setuid in the current packages.

Note You need to log in before you can comment on or make changes to this bug.