This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 536206 - (RHQ-581) support rendering list of simple props in UI, it isn't implemented right now
support rendering list of simple props in UI, it isn't implemented right now
Status: CLOSED DUPLICATE of bug 536139
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-15 22:45 EDT by John Mazzitelli
Modified: 2009-11-11 12:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-06-15 22:45:00 EDT
I need to specify a list of simple properties in plugin configuration.  When I define this in plugin descriptor:

            <plugin-configuration>
                <c:list-property name="acceptablePingStatusCodes" displayName="Accepable Ping Status Codes" required="false">
                   <c:description>If specified, these are the only HTTP status codes that makes the URL considered 'available'.  If not set, just successfully connecting to the URL makes the application considered available.</c:description>
                   <c:simple-property name="statusCode" type="integer" />
                </c:list-property>
            </plugin-configuration>

I get this in the UI when it tries to render it:

Rendering of lists of PropertyDefinitionSimple properties is not yet supported. Here's the list's toString() value for now: [PropertySimple[id=501607, name=statusCode, value=200, override=false]]
Comment 1 Joseph Marques 2008-06-16 00:22:18 EDT
yup, this is a known issue.  ian should be able to comment on what it would take to support this, as he wrote the bulk of the configuration stuff.
Comment 2 Red Hat Bugzilla 2009-11-10 16:12:20 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-581
This bug duplicates RHQ-521
This bug was marked DUPLICATE in the database but has no duplicate of bug id.
Comment 3 David Lawrence 2009-11-11 12:28:11 EST

*** This bug has been marked as a duplicate of bug 536139 ***

Note You need to log in before you can comment on or make changes to this bug.