Bug 536216 - (RHQ-590) externalize RHQ_* environment variables from Server and Agent start scripts into separate "conf" files (analgous to JBAS run.conf file or IntelliJ idea.exe.vmoptions file)
externalize RHQ_* environment variables from Server and Agent start scripts i...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 18:43 EDT by Ian Springer
Modified: 2013-02-26 17:01 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 17:01:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-06-17 18:43:00 EDT
These conf files (e.g. rhq-server-env.sh/bat and rhq-agent-env.sh/bat) would be sourced by the respective start scripts

This will allow users to externalize JVM, debug, etc. settings and easily migrate them when upgrading to a new version of JON, rather than having to merge their changes into the potentially updated start scripts.

Comment 1 Ian Springer 2008-07-17 11:39:00 EDT
Agent half of this is done - r1111.
Comment 2 Greg Hinkle 2008-10-02 13:32:13 EDT
server half of this will have to wait for 1.2
Comment 3 John Mazzitelli 2009-03-03 14:24:27 EST
do not touch the way the agent configures its env vars anymore - we now have the agent plugin able to modify the config and it requires things to be the way they are now (-env.bat.sh). agent auto-update also keeps these -env scripts so they are maintained during upgrades
Comment 4 Red Hat Bugzilla 2009-11-10 16:12:33 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-590
Comment 5 Joseph Marques 2010-10-05 12:04:24 EDT
ips, mazz - what (if anything) else needs to happen for this BZ?
Comment 6 John Mazzitelli 2010-10-07 08:52:54 EDT
nothing left to do on the agent side.

the server configuration is different depending on if you are on Windows or UNIX platforms (because of the usage of Java Service Wrapper on Windows) so its not going to be trivial to get the server to be easily configurable in the same way for both Windows and UNIX anyway.

I say we close this. The agent configuration was done but I don't think we need to do this for the server. The agent is the thing we most wanted to make it easier for upgrades and we did that.
Comment 7 Jay Shaughnessy 2013-02-26 17:01:44 EST
Closing, we're not doing this.

Note You need to log in before you can comment on or make changes to this bug.