Bug 53622 - konqueror crash
Summary: konqueror crash
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-13 08:12 UTC by Tim Waugh
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 08:12:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (2.16 KB, text/plain)
2001-09-13 08:12 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2001-09-13 08:12:17 UTC
Description of Problem:
Konqueror crashes when viewing 
http://www.newsnow.co.uk/cgi/NGoto/7731231?-461

Version-Release number of selected component (if applicable):
kdelibs-2.2-11
kdebase-2.2-12

How Reproducible:
100%

Steps to Reproduce:
1. View URL.

Actual Results:
Stack trace attached.

Comment 1 Tim Waugh 2001-09-13 08:12:43 UTC
Created attachment 31717 [details]
Stack trace

Comment 2 Bernhard Rosenkraenzer 2001-09-13 08:34:59 UTC
Works here, using the exact same packages... Maybe the content of the page has 
changed in between. (It's currently [cutting and pasting from another 
Konqueror window] a redirect to 
http://news.telegraph.co.uk/news/main.jhtml?xml=/news/2001/09/13/utower.xml, 
which states

Only one Trade Centre tower was insured
 (Filed: 13/09/2001) 


 ONLY one of the twin World Trade Centre towers was insured because experts 
believed the chances of both collapsing simultaneously was too far-fetched. 

The towers' owners, the Port Authority of New York, will only receive an 
insurance payout of around #1 billion, far below the #3.3bn value put on the 
towers before the terror attack, according to reports. 

A spokesman for the US Insurance Information Institute said: "The possibility 
of the loss of both structures was seen as so remote that cover was not taken 
out on those lines.")


Comment 3 Bernhard Rosenkraenzer 2001-09-13 10:28:36 UTC
The backtrace seems to be nonsentical... I don't see how 
CachedScript::checkNotify() could possibly crash, unless something VERY weird 
is going on (e.g. QList<> iterator broken, which it isn't).

void CachedScript::checkNotify()
{
    if(loading) return;

    CachedObjectClient *c;
    for ( c = m_clients.first(); c != 0; c = m_clients.next() )
        c->notifyFinished(this);
}



Comment 4 Tim Waugh 2001-09-13 11:02:38 UTC
It was that story before, yes.  But now, the telegraph URL works (as it did 
before, actually), but the newsnow URL _also_ works, which it didn't before.  
Odd.



Note You need to log in before you can comment on or make changes to this bug.