Bug 53628 - CyberBladeAi1 witn 8MB doesn't show arrow cursor
CyberBladeAi1 witn 8MB doesn't show arrow cursor
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 09:22 EDT by Jan Pazdziora
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 06:14:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config-4 (2.49 KB, text/plain)
2001-09-13 09:26 EDT, Jan Pazdziora
no flags Details
Log of the startx (with Gnome) run (22.37 KB, text/plain)
2001-09-13 09:27 EDT, Jan Pazdziora
no flags Details

  None (edit)
Description Jan Pazdziora 2001-09-13 09:22:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628

Description of problem:
I have a RH 7.1 and upgraded my XFree to Roswell's 4.1.0-0.9.13.
I have an Acer TraveMate 212TXV with CyberBladeAi1 chipset and
8 MB of memory. If I do not specify VideoRam, the trident driver
finds 8MB but uses 4MB. If I specify VideoRam 8192, the mouse cursor
is broken -- a weird rectangle instead of an arrow, or, it stays
as a cross in Gnome, instead of changing based on the window it's
on. I can use SWCursor to get the cursor right and I can use the
4096 setting, but with hardware cursor and 8 MB memory, I'm not
able to get decent mouse cursor.

The same problem was with 7.1 vanilla 4.0.3-5.

Version-Release number of selected component (if applicable):
4.1.0-0.9.13

How reproducible:
Always

Steps to Reproduce:
1. Start startx (triggers Gnome).
2. Watch the mouse cursor, it's garbled rectangle.
3. Repeat, it's still the same.
4. Start X, cursor will be a cross.
5. Start startx, it will be a cross, will not change to anything else.
	

Actual Results:  I got the basic X screen or Gnome screen, with either
garbled rectangle instead of the mouse cursor arrow, or a cross that
won't change to anything else. Actually, running X got to change the
cursor to cross, but that will not change anymore.

Expected Results:  The cursor should be nice cursor -- an arrow,
a hand, a cross, changing based on the desktop/window it's on.

Additional info:
Comment 1 Jan Pazdziora 2001-09-13 09:26:13 EDT
Created attachment 31736 [details]
XF86Config-4
Comment 2 Jan Pazdziora 2001-09-13 09:27:15 EDT
Created attachment 31737 [details]
Log of the startx (with Gnome) run
Comment 3 Mike A. Harris 2002-02-11 09:12:10 EST
Is this problem still present in XFree86-4.1.0-15 which we've released as
erratum for both RHL 7.1 and 7.2?  If so, many Trident related bugs are
fixed in the rawhide XFree86-4.2.0 which you may also want to try.

Please update report with current status, thanks.
Comment 4 Mike A. Harris 2002-03-14 14:00:54 EST
Closing bug awaiting feedback of requested information.  If the problem
persists in the versions listed above, please reopen report and include
information requested.  Thanks.
Comment 5 Jan Pazdziora 2002-05-15 06:14:40 EDT
I recently upgraded to RH 7.3 Valhalla which has XFree86 4.2.0-8.
The problem is still there -- if I don't use software cursor with 8 MB
enabled, the cursor is not properly shaped cross but a messed square.
With SWcursor, everything is fine. Maybe it could be closed as a feature,
I don't know.
Comment 6 Mike A. Harris 2002-05-20 19:18:54 EDT
I've set this card to default to using the software cursor in future
releases.  An updated hwdata package with this change should appear
in rawhide in the near future.
Comment 7 Mike A. Harris 2002-05-20 19:20:21 EDT
NAME Trident CyberBlade/Ai1
CHIPSET CyberBladeAi1
DRIVER trident
SERVER SVGA
LINE     Option "swcursor"
UNSUPPORTED
NOCLOCKPROBE

Note You need to log in before you can comment on or make changes to this bug.