Bug 53629 - SITE CHECKSUM violates RFC and causes client hangup or timeout
Summary: SITE CHECKSUM violates RFC and causes client hangup or timeout
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-13 13:42 UTC by Peter Surda
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 13:32:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Surda 2001-09-13 13:42:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-20mdk i686; en-US; Galeon)
Gecko/20010409

Description of problem:
According to RFC 959 or whatever, every command should be replied to.
However, if data has been transferred, SITE CHECKSUM doesn't produce a
reply. As I understand this is still unimplemented and should return an
error reply. The server doesn't freeze or anything, simply fails to produce
an answer and thusly the client freezes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. user + pass + whatever
2. retr or stor
3. site checksum	

Actual Results:  no reply, but daemon still works.

Expected Results:  an error reply should be produced

Additional info:

A fix is IMHO straigthforward, it should be a one-line patch. I don't think
it's critical, however causes temporary freeze on a rfc-compliant client
and hence should be fixed.
I'd have written to wu-ftpd directly, their site seems to be down however.
I hope this has nothing to do with the terrorist attack and none of the
developers were injured.

Comment 1 Thomas Woerner 2004-02-19 13:32:52 UTC
Please use vsftpd, wu-ftpd is not maintained anymore.


Note You need to log in before you can comment on or make changes to this bug.