Bug 536295 - (RHQ-660) Deleting event source gives IndexOutOfBoundsException
Deleting event source gives IndexOutOfBoundsException
Status: CLOSED DEFERRED
Product: RHQ Project
Classification: Other
Component: Events (Show other bugs)
1.1pre
All All
high Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
http://jira.rhq-project.org/browse/RH...
:
: RHQ-1232 (view as bug list)
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2008-07-09 15:33 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
JON 2.0.1GA, Linux
Last Closed: 2011-06-13 16:25:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhq-x.html (2.68 KB, text/html)
2008-07-09 15:34 EDT, Jeff Weiss
no flags Details

  None (edit)
Description Jeff Weiss 2008-07-09 15:33:00 EDT
See attached Selenium script to reproduce. (Note the first 2 lines of the script refer to the 2 log files, which need to be created or point to existing files before running the script)

essentially, create 2 event sources, OK the changes.  Now Edit again and Delete the 1st source, without clicking OK the 2nd time, try to edit the remaining source.
Comment 1 Jeff Weiss 2008-07-09 15:38:31 EDT
Stack trace:
java.lang.IndexOutOfBoundsException: Index: 1, Size: 1
	at java.util.ArrayList.RangeCheck(ArrayList.java:546)
	at java.util.ArrayList.get(ArrayList.java:321)
	at org.hibernate.collection.PersistentBag.get(PersistentBag.java:423)
	at org.rhq.core.gui.configuration.MapInListUIComponentTreeFactory.<init>(MapInListUIComponentTreeFactory.java:38)
	at org.rhq.core.gui.configuration.ConfigRenderer.addListMemberProperty(ConfigRenderer.java:141)
	at org.rhq.core.gui.configuration.ConfigRenderer.encodeBegin(ConfigRenderer.java:131)
	at javax.faces.component.UIComponentBase.encodeBegin(UIComponentBase.java:801)
	at javax.faces.component.UIComponent.encodeAll(UIComponent.java:934)
	at javax.faces.render.Renderer.encodeChildren(Renderer.java:148)
	at javax.faces.component.UIComponentBase.encodeChildren(UIComponentBase.java:825)
	at javax.faces.component.UIComponent.encodeAll(UIComponent.java:936)
	at javax.faces.component.UIComponent.encodeAll(UIComponent.java:942)
	at com.sun.facelets.FaceletViewHandler.renderView(FaceletViewHandler.java:592)
	at org.ajax4jsf.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:108)
	at org.ajax4jsf.application.AjaxViewHandler.renderView(AjaxViewHandler.java:216)
	at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:110)
	at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:100)
	at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:266)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:141)
	at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:281)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.rhq.enterprise.gui.legacy.AuthenticationFilter.doFilter(AuthenticationFilter.java:128)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.rhq.enterprise.gui.common.upload.MultipartFilter.doFilter(MultipartFilter.java:63)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.rhq.helpers.rtfilter.filter.RtFilter.doFilter(RtFilter.java:112)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
	at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
	at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
	at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:241)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:580)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
	at java.lang.Thread.run(Thread.java:595)
Comment 2 Greg Hinkle 2008-07-29 21:32:51 EDT
Ian, is this a general list-of-maps config editing problem that would cause other problems?
Comment 3 Joseph Marques 2008-09-15 09:37:47 EDT
this is not good.  we want users to have a pleasant experience with events, not to have to work around our bugs.  let's do some testing and see how reproducible this is.
Comment 4 Jeff Weiss 2008-09-15 10:45:10 EDT
There's a selenium script attached to reproduce.  I just ran it on rev1385 and got the same error.
Comment 5 Jeff Weiss 2009-05-08 15:39:19 EDT
I got a similar error trying to delete the 2nd source.  see linked dupe jira.  1.2.0GA.
Comment 6 Red Hat Bugzilla 2009-11-10 16:14:14 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-660
Imported an attachment (id=368875)
This bug is duplicated by RHQ-1232
This bug is duplicated by RHQ-2068
Comment 7 David Lawrence 2009-11-11 12:08:31 EST
*** Bug 534437 has been marked as a duplicate of this bug. ***
Comment 8 Ian Springer 2011-03-10 16:53:59 EST
This is no longer an issue in the new GWT GUI (coregui.war).
Comment 9 Mike Foley 2011-06-13 16:25:18 EDT
no longer relevant in GWT.

Note You need to log in before you can comment on or make changes to this bug.