Bug 536300 - (RHQ-665) Remove use of full screen modal message boxes
Remove use of full screen modal message boxes
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
: RHQ-356 RHQ-610 (view as bug list)
Depends On: RHQ-2463
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 14:44 EDT by Jason Dobies
Modified: 2010-12-23 09:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-23 09:52:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot-1.jpg (225.42 KB, image/jpeg)
2008-07-11 14:45 EDT, Jason Dobies
no flags Details
text encoded now.jpg (34.92 KB, image/jpeg)
2008-12-19 04:00 EST, John Mazzitelli
no flags Details
op-results.jpg (67.29 KB, image/jpeg)
2009-03-23 11:53 EDT, John Mazzitelli
no flags Details

  None (edit)
Description Jason Dobies 2008-07-11 14:44:00 EDT
Collected from a number of other JIRAS. Known occurrences:

- Failure link in operation history details
- In a content source the "Click to view..." link in the Synchronization Results table

Comment 1 Greg Hinkle 2008-10-02 11:29:53 EDT
not critical, pushing
Comment 2 John Mazzitelli 2008-12-19 04:00:05 EST
This popop looks even worse now - its  url encoded.
We need to fix this.
Comment 3 John Mazzitelli 2008-12-19 04:05:29 EST
Joe - didn't you change something recently that might make this message better formatted now? I think it was you that did the url encoding and I think it requires that we change the JSF xhtml to take advantage of it.  Please comment on what needs to be changed.

If we could just get this message to show unencoded with the newlines properly showed, this message would be OK.  The problem has always been the newlines were stripped out and everything ran together.
Comment 4 John Mazzitelli 2009-01-08 12:28:30 EST
opps... meant to assign to jay, not me.

jay - is this potentially fixed with some recent changes of yours (or joes?)
Comment 5 John Mazzitelli 2009-01-20 08:46:25 EST
not fixed yet - RHQ-1380 was opened (I closed that one because its a duplicate of this one, but that at least tells me this isn't fixed yet)
Comment 6 John Mazzitelli 2009-02-24 00:43:13 EST
use RF modal dialogs, e.g:

                  <h:outputLink rendered="#{syncitem.results ne null}"
                                value="#" id="resultsLink">
                     <h:outputText value="Click here to view..."/>
                     <rich:componentControl for="resultsModalPanel" attachTo="resultsLink" operation="show" event="onclick"/>
                  </h:outputLink>
                  <h:outputText rendered="#{syncitem.results eq null}" value=""/>
                  <rich:modalPanel id="resultsModalPanel" width="350" height="300">
                     <f:facet name="header">
                        <h:panelGroup>
                           <h:outputText value="Results" />
                        </h:panelGroup>
                     </f:facet>
                     <f:facet name="controls">
                        <h:panelGroup>
                           <h:graphicImage value="/images/close.png" style="cursor:pointer" id="resultsModelPanelHideLink"/>
                           <rich:componentControl for="resultsModalPanel" attachTo="resultsModelPanelHideLink" operation="hide" event="onclick"/>
                        </h:panelGroup>
                     </f:facet>
                     <PRE><h:outputText value="#{syncitem.results}" /></PRE>
                  </rich:modalPanel>

still haven't figured out a way to get the newlines to render. I really don't want to have to code up some conversion in the UI bean, but I think that's what it will have to end up with.
Comment 7 John Mazzitelli 2009-02-24 00:54:03 EST
svn rev3164 fixes the content source page. still need to figure out how to render newlines, but the %20 garbage is gone on this page.
Comment 8 John Mazzitelli 2009-02-24 01:40:09 EST
svn rev3166 uses  <pre> tags so the newlines render. this is fine since we are rendering some raw output/logs that looks ok in <pre> tags
Comment 9 John Mazzitelli 2009-02-24 01:42:05 EST
Do a search for all .xhtml files that use "javascript:displayMessageModal" - there are alot of them. We should use this RF modal dialog for all of these to maintain consistency.
Comment 10 John Mazzitelli 2009-03-23 11:53:30 EDT
op-results snapshot shows the problem when looking at the operation results failures
Comment 11 John Mazzitelli 2009-03-23 12:39:14 EDT
svn rev3504 fixes that op-results failures dialog
Comment 12 John Mazzitelli 2009-03-23 12:58:50 EDT
svn rev3506 fixes the group op details page
Comment 13 John Mazzitelli 2009-03-23 13:15:52 EDT
There are now 5 places left in the code that uses this message modal:

configurationUpdate.xhtml - rhq/modules/enterprise/gui/portal-war/src/main/webapp/rhq/subsystem
groupOperationHistory.xhtml - rhq/modules/enterprise/gui/portal-war/src/main/webapp/rhq/group/operation
history.xhtml - rhq/modules/enterprise/gui/portal-war/src/main/webapp/rhq/resource/configuration
history.xhtml - rhq/modules/enterprise/gui/portal-war/src/main/webapp/rhq/resource/inventory
operationHistory.xhtml - rhq/modules/enterprise/gui/portal-war/src/main/webapp/rhq/subsystem

The problem is, all 5 occur inside a rich:dataTable. As such, multiple rows are rendered with this "javascript:displayMessageModal". The problem here is if we have multiple places in the page that render this, we cannot define multiple element ids. We would need to be able to do something like this:

   <h:outputLink rendered="#{syncitem.results ne null}"
      value="#" id="resultsLink" + ROW_INDEX_HERE>
...
      <rich:componentControl for="resultsModalPanel" attachTo="resultsLink"+ROW_INDEX_HERE ...
...
      <rich:modalPanel id="resultsModalPanel" + ROW_INDEX_HERE ...
...
             <h:graphicImage ... id="resultsModelPanelHideLink" + ROW_INDEX_HERE />
             <rich:componentControl for="resultsModalPanel" + ROW_INDEX_HERE attachTo="resultsModelPanelHideLink" + ROW_INDEX_HERE ...

Because we have the potential to needing to show a "Failure" link in multiple rows in the data table, we need a way to share a single model panel. I'm sure it can be done, I just haven't looked into how to refactor the example code shown in this jira issue to do it.

Comment 14 Joseph Marques 2009-03-23 13:57:04 EDT
mazz, take a look at the events history page.  i did something where i used a single modal to display the details of the click event on the event row.
Comment 15 Joseph Marques 2009-03-30 09:32:16 EDT
also, need to make sure that the scrollbars show appropriate for clipped content:

use style="overflow: auto;" on the modalPanel itself
use style="white-space: pre-wrap; font-family: Courier New, monospace;"

see rev3554 for a template of this.
Comment 16 Red Hat Bugzilla 2009-11-10 16:14:19 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-665
Imported an attachment (id=368876)
Imported an attachment (id=368877)
Imported an attachment (id=368878)
This bug is related to RHQ-610
Comment 17 David Lawrence 2009-11-11 12:25:28 EST
*** Bug 535955 has been marked as a duplicate of this bug. ***
Comment 18 David Lawrence 2009-11-11 12:28:38 EST
*** Bug 536239 has been marked as a duplicate of this bug. ***
Comment 19 wes hayutin 2010-02-16 12:08:22 EST
mass add of key word FutureFeature to help track
Comment 20 Corey Welton 2010-12-23 09:52:32 EST
closing per gwt effort

Note You need to log in before you can comment on or make changes to this bug.