Bug 536323 - (RHQ-686) support listing available property names for bracketed expressions
support listing available property names for bracketed expressions
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: SubFeature
Depends On:
Blocks: RHQ-399
  Show dependency treegraph
 
Reported: 2008-07-16 17:50 EDT by Jay Shaughnessy
Modified: 2014-11-09 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2008-07-16 17:50:00 EDT
today we have three bracketed expression tokens: traits, pluginConfiguration, resourceConfiguration

their expressions look something like:

resource.trait[<property_name>]
resource.pluginConfiguration[<property_name>]
resource.resourceConfiguration[<property_name>]

the UI needs to somehow show what the available property names are.
Comment 1 Joseph Marques 2008-07-18 10:55:30 EDT
this is related to RHQ-401, but is a simpler way of getting users of the system up and running with dynagroups without having to build a large expression builder.  a library / look-up mechanism would get users 80% of the way there, and only require 20% of the effort a full expression builder would take.
Comment 2 Joseph Marques 2008-07-18 13:05:32 EDT
rev1113 - support a property name library for lookup up properties;
properties can be traitNames, pluginConfigurationProperties, resourceConfigurationProperties;
properties are classified by the plugin and resource type they belong to;

rev1115 - since ewe allow both null/missing and empty tags for certain parts of the rhq-plugin.xml, let's be a little more proactive in catching errors in both of those cases;
Comment 3 Joseph Marques 2008-07-18 13:05:44 EDT
you can see this feature by going to the view or edit page for any individual group definition. click the blue question mark icon at the upper right-hand corner of the textarea for the group definition conditions box.

so far, this is just the raw functionality. i'll leave it up to testers / other devs to decide whether it need to be made "pretty".
Comment 4 Jeff Weiss 2008-08-04 16:12:56 EDT
This feature will be fully incorporated into RHQ-401.  No need to test features that will be replaced anyway.

<ghinkle> consider 686 to have been sucked into 401
Comment 5 Red Hat Bugzilla 2009-11-10 16:14:44 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-686
This bug relates to RHQ-401

Note You need to log in before you can comment on or make changes to this bug.